Digital Audio possible with XBMC?

Hello,

I am using the latest nightly version of XBMC. I have some mkv Files with Dolby 5.1 or DTS audio line. But XBMC is only playing in normal Stereo. Is possible to get digital audio?

If you are using an Optical audio to your amp, I am wondering if you have the audio playback settings in XBMC setup correctly … I have the digital/coax setting enabled and seems to get DTS, THX & Dolby 5.1 audio on my Denon AVR. The Denon is set to autodetect the audio input. I run the HDMI out from the aTV2 to a video input on the Sony Bravia TV. All video & audio switching is done with a Logitech One Remote. Both my appleTV and the aTV2 have the same connection types.

I only see auto and 16 bit in my choices. Is there a menu trick to see 32 bit?

Sorry, :[ I was trying to do it from memory. indeed it should be set to 16 bit rather than auto. Once you have done this in the XMBC settings, audio option, you can enable AC3 (5.1 and Dolby Digital) as well as DTS pass thru.

 

apologies for an confusion I have introduced.

 

PS once you have it working give the ICEFILM plugin for XMBC a go. loads of 5.1 enabled content in Movies and TV Shows, all streaming directly to your ATV2. Awesome.8)

This took me a long time to figure out. Ironically the setting you need to change to get it working in XBMC isnt in XBMC.

 

return to the default ATV2 menu and from the setting, Audio/Video, you need to change the audio option from Auto to 16 Bit.  After I had change this my AV came alive. I never had a problem with ATV2 playing 5.1 & DTS in Auto, but XBMC was a particularly unpleasant having PCm blasted out of all the speakers at a high volume setting.

 

Hope this makes sense. 

Thank you, but this doesnt work. It doesnt matter if I choose Auto or 16bit in ATV settings. In XBMC you can choose AC3 and DTS if you set the audio to HDMI. You cabt choose AC3 and DTS if you choose analog. But it doesnt matter what you choosed in ATV settings.

But I never cant choose something with “passthrough”. Where do you see this option?

Same here. ATV2 set for 16 bit. Have tried more than once. Set to Coax/Optical  and choosing AC3 and DTS does not work in XBMC. Have standard confluence skin. Have never altered.