Did I just brick my new Apple TV???? :-O

A new from the box Apple TV 2 that came with 4.4.3  Used Seas0nPass -the latest for Mac 0.8.3  and (tried, I think) downgraded to 4.3… (right clicked and selected the Firmware 4.3)  iTunes showed it uploaded all… “restoring Apple TV software”… “iTunes restored script successful!”, “your Apple TV has been restored to factoring settings, please disconnect and reconnect to TV… etc.  I did not get a message telling me if the device was jailbroke (untethered/tethered).  When I connected the APTV2 to the TV, it showed the iTunes/USB image.  I went ahead and connected the APTV2 again to my MacBook using the micro USB and tried to create the IPSW again (same process mentioned above).  Got the same result.  I reconnected the APTV2 to the  TV and still have the iTunes/USB image.  Reconnected to the MacBook and decided to click on the “Boot Tethered” since I have the iTunes/USB image each time I tried….  Then, I got the message “Tethered Boot complete”.

 

Does that mean that after downgraded to 4.3 it did a Tether Jailbreak???  I thought 4.3 was an untethered jailbreak.  Anyway, after receiving the message that the “Tethered boot” was complete, I connected the APTV2 to my TV and the freak*** iTunes/USB image is there again!  What I’m doing wrong?

 

I have read soooo many threads and I’m still confused.  Please help this newbie; it will be greatly appreciated.

Wow where to start.

You cannot downgrade unless you have you SHSH blobs saved and signed to the ipsw, that is probably why you are getting the boot tethered logo.

Have you saved your SHSH blobs at 4.4.3?

If so follow this post http://forum.firecore.com/topic/7292

If you have not saved your blobs then you will have to update and use tethered boot untill untethered boot JB comes out

Thanks Flipmode for your reply.  What if I saved the firmware friom i.e. iClarified website? (they have a list with different Firmwares for download) and I saved the 4.3 Firmware.  Is the ‘Firmware’ the ‘SHSH Blobs’?  However, I did the process mentioned on my original post following this thread http://forum.firecore.com/topic/6317 that says that it’s not neccessary to have the SHSH if you edit the host files.  Unfortunately, the thread that you are suggeting does not work with Macs… :frowning: I’m willing to do an untethered jailbrake.  How to do it from where I’m at?  Thanks again.

Let me break this down for you.

The IPSW you download from iClarified or ANY other website is not the SHSH blobs. SHSH blobs are device dependent. Which means (theoretically) you cannot use blobs from different devices to flash any IPSW. Editing your HOSTS file will not simply allow you to flash any firmware you’d like to. You need to mimic the signing server from Apple so that the firmware is marked as being signed and eligible to be flashed. Apple turns off the signing of IPSWs shortly thereafter a newer version being released so that everyone is running “the latest and greatest”.

Again an IPSW is not an SHSH blob.

Thank you for the clarification and explanation Matty.  But I have a question since I did not used the firmware I saved from iClarified when I followed what is on the thread I mentioned….http://forum.firecore.com/topic/6317  Apparently people had success following the thread instructions even after Apple stop signing 4.3… and the OP says that you don't need to have the SHSH Blobs.  What are the Firmware that are shown when you right-click where it says 'create IPSW'?  Again, sorry for my newbieness.

 

Anyway, like I said before, I still want to Jailbreak even though is a tethered Jailbreak.  What are the steps I would need to follow now that I have done all this and I’m still getting the iTunes/USB message?  I would like to start from scratch….  Thanks!

   

No - Seasonpass does not have the blobs saved (they are very small files that contain the digital signatures that are specific to your ATV hardware and a particular firmware version).   Normally these signatures are created by Apple when you restore firmware, but since Apple has stopped signing any firmware except the 5.0 version you have to both already have the blobs saved for the target release if it is not 5.0 and a way of simulating the Apple servers that normally do the signing.

In your case I would think that the easiest way forward would be to go to the 5.0 firmware (and live with it being a tethered boot jailbreak) as this is still being signed by Apple so jailbreaking to that release is comparitively easy.   Sometime in the near future it is expected that an untethered jailbreak for 5.0 will become availalbe and at that point one can re-do the jailbreak process to get an untethered jailbreak.

iClarified is not always up to date, that was problem #1

Problem #2 no Blobs were saved you will have to go with 5.0 and tethered

Thank you itimpi and all others.  I have really learned a lot from yours answers.  I can leave with the tethered jailbreak and keep the hopes for an untethered one.  So it just a matter to connect the APTV2 again to my MacBook and run the last Seas0nPass where it says create IPSW?  Will it automatically be 5.0?

Yes. Just click Create IPSW and it will download the latest version and jailbreak it. You must then click the boot tethered button after you’re finished.

Ok.  Thanks again!  

:slight_smile:

Hold on a minute!  Before you go irreversibly update to the tethered 5.1, 4.4.3 has an untethered jailbreak.  Why do you want to downgrade to 4.3?  Have you tried jailbreaking it in 4.4.3 yet?  I would suggest you exhaust all possibilities before IRREVERSIBLY updating to the latest firmware.  4.4.3 is perfectly fine for an untethered jailbreak!

Reread his post again that will answer your reply.

Please don’t confuse me more…   =O   as far as I know there is no untethered jailbreak for 4.4.3.  Guys please confirm if otherwise… 

 

Here is your answer: http://forum.firecore.com/topic/3418

4.4.3 is also the most stable firmware for running XBMC…

No it does not.  Again, I would suggest that you exhaust all possibilities before IRREVERSIBLY upgrade to the latest firmware!  It’s clear you are not on a vanilla 4.3 or jailbroken 4.3.  The shsh signature might still be 4.4.3 in your unit.  If true, you could possibly go back to vanilla 4.4.3 and perform the 4.4.3 jailbreak from there… Just my opinion. 

 

I hope you are right for his sake, he has already programmed it wrong to start with.

 

badassdes Follow this post and you may get lucky http://forum.firecore.com/topic/7292

 

If you reread his first post, you will find out that he runs OSX.  Here is a list of what I would do (in this order):

1.  Redo what you described in your first post, but this time do it for 4.4.3 instead of 4.3.

2.  Use TinyUmbrella (http://thefirmwareumbrella.blogspot.com/) to save your shsh.  If it captures your 4.4.3 signature, then you are golden!

 

Good luck!

 

 

I have access to a PC too.  Tried to do what you suggested on the thread http://forum.firecore.com/topic/7292 but the process stopped when iFaith says “unknown iOS version detected” and then aborts.  I think my APTV is already screwed…  :frowning:

As a newbie (should say idiot!) I did not saved the 4.4.3 SHSH of my new device (didn’t know).  Can I still try what you posted last?  To do what I originally did but creating the IPSW 4.4.3 instead of 4.3?  Remember: I did not saved the SHSH blobs.

Thanks

 

Some users have keep trying when getting that message so keep trying and hopefully it will get past that error.

 

You can try tinyumbrella as stated but if you are in tethered mode you need to do a tethered boot to get tiny umbrella to recognize the apple TV, something the great wizard above forgot to tell you 

OK.  I did the original process again but with 4.4.3… “iTunes restored script successful!”, “your Apple TV has been restored to factoring settings, please disconnect and reconnect to TV… And, it happened again. I did not get a message telling me if the device was jailbroke. Connected the APTV to the TV and It showed the iTunes/USB image again.  Tried with TU as suggested and it doesn’t recognize the device.  There is a question mark and it says it’s not connected.  It’s like the device doesn’t have any firmware… like it’s ‘hollow’… sigh