DFU MODE Query

I have read a lot of other posts before 'duplicating' what others are also experiencing.

I purchased an Apple TV2 yesterday so guess it has the lastest firmware on it.  I have tried to get it into DFU Mode only to be shamed by the ATV refusing to enter this mode.

I have tried all the combinations of Apple Remote key pressing with no success.

One query I do have though is that if I have the Apple TV plugged into my Macbook by means of just the micro usb cable should there be any lights on the ATV?  I have no lights at all (only lights come on when power is plugged in)  I have also checked via the Mac and 'About this Mac' and can not see any extra devices plugged into the USB port as you might see for example if you had a camera connected.

Is there a way of testing the USB port to make sure its OK?

Are there any automatic tools for getting the ATV2 into DFU mode?

 

I cannot stress the importance of not installing the season pass on an external drive.  Install and load from the primary drive, which your OS is on. VITAL

call resolved.  Was the USB cable at fault