Dfu issue during jailbreak

I am trying to jailbreak my Apple TV 2 using season pass 1

When I start the process I believe the unit is going into dfu mode as I tune starts and and asked if I want to to recover that Apple TV

I am then trying to create the custom firmware and the process seems to be working but it gets to the end and and then says it cannot get into dfu mode not sure what to do please help

TIA Bart

What system are you using?
I had issues with Windows 10 Version 1909, and it always failed after creating the firmware, and tried everything.
I read on a post that some hardware causes problems, so luckily I had an older system, very basic, but still Windows 10.
I would guess that due to the simplicity of the computer, I was able to restore, create firmware, upload full install, install aTV Flash, and so on.
Don’t know if this will help you, but, using a very basic older all in 1 Windows 10 system is what saved me.

I’m using the latest version of Windows 10 as I just had a bunch of updates.
Gonna try using a friend’s laptop which I think is running 7

I have tried several different Windows and OSX platforms and still the jailbreak fails. Mostly with “SeasOn Pass does not support this device” or “failed to reset USB counters.”