Deleted movies still in library

Dear guys,

I think since the update to Infuse 6, when I delete files from my Synology NAS, they won’t get deleted in Infuse. The NAS is connected via SMB and I delete the files not with Infuse but directly on the NAS itself. I’m not sure, if it also happens when I delete tv shows, I do not delete them very often. When I click on a movie, there is no information and i get an error when trying to play one (the movie does not exist). The deleted movies are also still in my lists (e.g. latest movies or best rated movies etc.).
Does anyone else has this problem or how to solve it?
PS: I got two Apple TV 4K and use iCloud synchronization.

Can you try running the scan for change option in Settings > Library to see if the deleted items are removed?

Are these files visible while browsing via folders, or just the library?

1 Like

So I went to “Settings → Library” and clicked on “scan for changes” (In german it is “Nach Veränderungen suchen” - I do not know how exactly it is called in english). But after that, my deleted movies are still visible in the library and my lists (no metadata, just the name and the cover). These movies are NOT visible when I browse through folders…

I installed the iOS app on my iPhone… On the iPhone these files are not visible, not in the library nor via file browsing…

I just checked on my second Apple TV and here are also still the deleted movies…
Should I delete the App on both Apple TVs and reinstall them? Since I got my library in the iCloud, it should work, right?

If you have a chance, can you walk through the following steps so we can help troubleshoot this further.

  1. Duplicate one of your videos and give it a random movie name (maybe a name of a movie you don’t actually have, just so it can be easily identified)
  2. Allow Infuse to index this new movie, or tap the ‘Scan for Changes’ button
  3. Confirm the movie is visible in Infuse’s library
  4. Delete the movie from your share (as you have with other videos)
  5. Allow Infuse to scan for changes, or select the option manually
  6. Confirm the video is still present in the library, while not present while browsing via a folder
  7. If the movie is visible in the library, submit a report from your Apple TV (Settings > Submit Diagnostics). You can post the 5 digit code here, or open a support ticket as directed by the Apple TV (also be sure to let us know the name of the video that was added and removed).
1 Like

Hi… so I deleted Infuse on both of my apple TVs… after a reinstall, the deleted movies were gone. Now I just reproduced this issue by deleting a movie. Unfortunately this movie is still visible in Infuse.
My support code is
ZG8R7

Oh and it happens with every
Movie, this time it was „Pacific Rim 2“

Thanks! We’ll take a look.

1 Like

We’re still looking into this, but haven’t had any luck replicating this here.

Is this still an issue for you in the current 6.0.6 update? If so, would you mind answering a few questions?

  1. Do you have Recycle Bin enabled on the Synology NAS? Does the file remain visible after cleaning up Recycle Bin?
  2. What was deleted, the file, or the folder?
  3. Can the issue reliably reproduced and if so…
    3.1. Does the file remain visible in Add Files on iPhone or under Settings > Shares > Your Share > Add Favourite?
    3.2. Does the file remain visible in the Library categories, e.g. By Genre?
    3.3. Does the file remain visible after the app is killed via task manager?
    3.4. Does the file remain visible after a manual rescan is completed?
  4. Does the file remain visible if it was deleted via Infuse?
1 Like

Hi,

Is this still an issue for you in the current 6.0.6 update? If so, would you mind answering a few questions?
→ Yes, I just updated to 6.0.6, and this is still a issue. That means, that my last test movie (Pacific Rim 2) is still visible in:

  • lists
  • library
  • my favorites

The interesting thing is, that I copied a movie and renamed it to Pacific Rim 2 (for test purposes).
On Infuse on my Apple TV (living room), I checked for updates and Infuse found the file and downloaded all meta data etc. Everything is fine. Then I deleted the file and checked again for updates, but the movie is still visible, but not playable not any meta data, in Infuse.
Then I went to my second Apple TV (bed room), turned it on and checked for updates. Here no new file was found. I was a little bit confused, because I use iCloud Sync. The same on my iPhone, I checked for new updates and no new file was found. I mean, there is no new file anymore.

Do you have Recycle Bin enabled on the Synology NAS?
→ No, the file is definitely completely deleted.

Does the file remain visible after cleaning up Recycle Bin?
→ No Recycle Bin, therefore no.

What was deleted, the file, or the folder?
→ The folder. The file was in the folder. (Structure is like: „/Movies/Pacific Rim 2/Pacific Rim 2.mkv“)

Can the issue reliably reproduced and if so…
3.1. Does the file remain visible in Add Files on iPhone or under Settings > Shares > Your Share > Add Favourite?
→ No, I can’t see the file (or folder), because the folder not present on my NAS.

3.2. Does the file remain visible in the Library categories, e.g. By Genre?
→ Yes, I just checked, the movie is still visible in library categories.

3.3. Does the file remain visible after the app is killed via task manager?
→ I closed the app and rebooted the Apple TV. The movie is still visible.

3.4. Does the file remain visible after a manual rescan is completed?
→ As I already told, I reinstalled the whole app. After that, the deleted movie was not visible.

Does the file remain visible if it was deleted via Infuse?
→ I don’t use that option, but just enable it. I tried to delete the movie via Infuse and I get an error (in german „Ein Fehler ist aufgetreten“, in english it should be something like „An error occured“.

All in all I do not know where the problem is, I think it is a bug.
I hope my answers are detailed enough. biggrin :smiley: :smiley: +D =D :biggrin:

Thanks for the info.

If you have a chance, would you mind sending in a new report from the device you used when attempting to delete the file (via Infuse) and post the new code here?

Hi. I just tried to delete the movie via Infuse and get an error again.
Here is the code:

0XAGZ

I can confirm that this does not happen with TV shows…
I just deleted a TV show on my NAS itself and after I checked for updates in Infuse the TV show was gone.

Thanks.

We believe we’ve tracked down what’s going on here, and it only appears in certain cases where nested Favorites are being used.

We’re working on a fix, and will have more news soon.

1 Like

A fix for this has been added in the 6.0.7 version, which we’re submitting to Apple today.

Thanks for your patience. :slight_smile:

1 Like

Thanks, you are a great team!
Have a nice weekend!

Hi James,

this seems to be not an issue anymore in Infuse 6.0.7. Thank you!

1 Like

Great to hear. Enjoy! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.