Delay anytime I press play, pause or seek forwards, backwards

I’m running infuse on my Apple TV 4K with a SMB share on my Synology NAS hooked up via ethernet.

Whenever I play a video file, there is a half second delay anytime I press play or pause or seek forwards or backwards. The use case I see every time with every video file is I’m watching the clip (it starts and loads just fine) and then I click the apple siri remote to seek forward 10 secs, infuse has a lag/delay and then the video starts playing again (sound will lag even more before). Plex doesn’t do this so I think my setup is fine.

The files are simple 720p .mkv video files. I also re-encoded one of them to .mp4 which plex showed it was playing as a Direct Stream (so no conversion necessary) and that one even lagged.

I can include a video clip showing this behavior if you want.


Welcome to the forum!

Synology has the option to enable secure packet signing, which can add quite a bit of overhead when streaming.

You can try disabling this on your Synology, or manually adjust the SMB version in Infuse (select something other than Auto or SMB3) to see if this makes a difference.

I already have “Transport encryption mode” set to disabled on my Synology NAS. I also tried using NFS and that behaved the same also. I also just now edited my share to use SMB2 and the delay was still there.

I used to have a Mac Mini hooked up to my TV and I’d stream content from my NAS just fine. Seeking forwards and backwards would take milliseconds.

Many users have found they get best results using the “Legacy” setting on SMB… May be worth a try.

I just tried Legacy and it wasn’t any better. Attached are my settings.

The behavior can be seen here:

Thanks for the video.

I’m not seeing anything that’s standing out as an obvious problem, but one thing you can do to avoid the audio delay is change the Apple TV > Settings > Video and Audio > Audio Format > Change Format from Off to Dolby Digital 5.1 or Stereo.

It’s already set to Dolby Digital 5.1.

I can show a video of how plex handles seeking in a video. It is near instantaneous, maybe a few milliseconds delay. With infuse, it’s like a 1/2 second delay. When you go to skip some commercials and press seek many times in a row, it’s like it’s in quicksand. It’s painfully slow and delayed.

Or if you seek backwards 10 secs, instead of it being instantaneous, there’s a delay of a half second for the video and probably a full second for the audio. You’ll see people’s mouths moving before the audio comes back in again.

Here are 2 videos showing plex vs infuse:
Plex - plex
Infuse -

Here’s one showing a simple seek backwards. There’s about a 1 second delay.

Another example showing 2 separate seeks backwards and each one has a delay. One of them prompts the wait spinner to appear.

Same video as above but using plex. Notice how the seek backwards is instant.

1 Like

Any update to this? I’ve attached video files showing the behavior.

1 Like

I’m having the same problems but with even more delay when set to 5.1.
Here are two videos to compare:

Infuse with delay:

Plex without delay:

This issue and the missing end-time are still keeping me from using Infuse over Plex on ATV right now. Any more news?

I know this thread is old but I am also experiencing this delay and it’s really annoying. Plex does not do this. Even though I could see infuse is caching, this delay should not happen.

Note that I have been an infuse user for a year now and this issue is prevalent since I started using this app.

1 Like

See also:

Yep, that’s what I said years ago. I’ve submitted multiple bug reports with videos and it still isn’t fixed. I do a lot of skipping on my video files and this makes Infuse unusable for me.

1 Like

Delay issue still exists and being ignored…
Any feedback would be greatly appreciated! Thanks.

According to this post, the dev team is still aware of this problem:

I’m no dev and have no clue why this is so hard to get fixed. What i know is that all other apps i’ve tried - Plex, MrMC, Emby and of course every app that uses the native player - don’t have this delay issue.

Please, give this more priority and fix it! ?

As far as I know from previous comments I have seen by James, Infuse does not use the native player which may be why it is difficult to fix in Infuse.

I know that. But the mentioned apps also don‘t use the native player anymore and still don‘t have the delays.

Long standing beef of mine here also. The situation is a little improved in Infuse 6.3, but still not quite there yet.

Please discuss in this thread. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.