Delay after skipping/scrubbing

Video stops for 1-3 seconds (depending on audio format and video resolution) after every skip or scrubbing before resuming.

These delays are only happening with Infuse. No other apps i’ve tested (including Plex, Emby, MrMc or Apples native video player) have that issue and are resuming instantly as it should be.

I’ve posted about this back in October '19 and provided some videos for comparison.

Infuse with delay:

Plex with no delay:

Info about my setup:

And the diagnostic codes i’ve proved back in March `20:

AAC 2.0 --> (almost) instant resume after skipping
F53J4

DD 5.1 --> 1-2s delay when skipping
C44SM

DD 5.1 + 4K --> up to 2-3s delay when skipping
BS9MS

So @james, what else can i do to finally get you guys looking into this?

2 Likes

@james
I know it’s more than unlikely to happen, but is there a chance to get an option to switch back to the native ATV player?

All my media is Apple compatible encoded - so that would at least for me solve ALL playback issues i have with Infuse’s player.

Please respond. Thanks.

Another comparison between Infuse’s player and Apple’s native player (Computer app via Home sharing) with HD and 4K content:

Apple native player

Infuse player
https://streamable.com/e96g8j

While Apple’s native player resumes instantly when skipping and fast forwarding, Infuse’s player can’t barley handle the 4K version.

Why is that?

1 Like

Is really nobody else experiencing this?

I’d be thankful for ANY input here, please!

Hey :wink:
I think it depends on which Audio Type the file use…

Most of my Files has AAC 2.0 (Stereo), there is the skipping a little bit faster.
But with 5.1 Audio or even HD-Audio, the Skipping is really slow :pensive:

James, is there a possibility to make the Skipping with High Quality Audio faster (like the native tvOS player)? :wink::+1:

@james, clearly this has to be a bug with Infuse’s player. Please respond and help getting it fixed! Thanks.

We’ll take a look. Thanks.

1 Like

We did a few tests, and the seek times were reasonably low, typically under one second.

Upon closer inspection, we noticed a few things to optimize and managed to slash a little time for most of the files. We’ve also tuned up the spinner display to avoid blinking and make things smoother.

The attached video shows the new version (top) vs current (bottom).

2 Likes

That looks great. Thanks for looking into this. Will this be available in the next beta?

My delay issues have probably something to do with my audio connections. Have you tried using a HDMI-splitter with audio extraction via Toslink?

Looking forward to try out the new fix! Thanks.

These skip/seek delays have been a pet peeve of mine for more than a year now. I have sent a steady stream of feedback through open support tickets. With Infuse 6.3.3 I really thought the problem was fixed, getting <1s delay for the heaviest video formats, but the problems came back some time later.

1 Like

Today’s 6.4.8 update adds a number of improvements which should have a positive impact on all file types.

1 Like

Nothing has changed for my part. Delays persist and increase with audio/video format as described.

@james have you tried to test on a system with HDMI splitter and audio extractor via Toslink? I can only imagine, that it maybe has something to do with that.

Yes, Infuse (tvOS) 6.4.8 is (on my side) once again blazing fast. I tested two mkv files: 1080p/sdr/x264/DD5.1 and 2160p/hdr/HEVC/TrueHD7.1. Both handled 10s seeks/skips with delay < 0.5s. Both improved from earlier versions. Perfect.

Thanks, so happy! :smile:

1 Like

Can you tell me how your Apple TV is connected?

Can you try testing without this splitter in the pipeline to see if there’s an impact?

My ATV is playing video files over Gbit ethernet from a Windows smb2 server. In my experience, with extensive testing, the seek times are unaffected by network performance as long as the seeks are in the Infuse read buffer. You can see the extent of the read buffer on the time progress bar. Of course, Infuse also has a nifty network speed test. My Infuse speed is 150Mbps for smb2 and 700Mbps when Infuse uses a Plex Server.

A post was split to a new topic: Plex speed test no longer working in 6.4.8

I cannot test with a regular TV. However i did connect my projector directly via HDMI and my computer monitor (both have no audio input). But the delays are the same.

Again – no delays with other apps in combination with the HDMI splitter (Toslink). So it must have something to do with the way INFUSE handles that non-HDMI-audio…?

PM sent.

@james
Skipping issues still persist. Take a look at this video:

First part shows PLEX with perfect skipping behavior. Second part shows INFUSE – same video, huge delays in comparison; no audio after video resumes (kicks in about 1 second later).

Why is it SO HARD to fix this?

A month ago i was sent a beta version of INFUSE with heavy logging. I did everything according to your instructions and provided instant feedback. Nothing has been resolved (although release notes for 6.5 claim otherwise) and no further response until today.

If i sound pissed, that’s because i am! It’s an essential part of the user experience and it frustrates me every time when using INFUSE.