Deinterlace on HD Videos?

I have been recording TV via a HD Homerun and using Infuse 5.5.x to watch them. I noticed a lot of jutter last night when watching Star Trek: DIscovery. I am pretty sure the video is not being deinterlaced (since CBS out here in SF Bay Area is 1080i). When I played the video in MrMC it was fine because MrMC has software deinterlace. I read in one of the threads here that deinterlacing only works on SD videos, is that true? And if it is, will it come to HD videos any time since it looks like MrMC can do it via software without any issues.

Deinterlacing is available in Infuse for SD and HD videos. It’s enabled by default, but you can toggle this on/off through the Video tab of the playback menu (swipe down while a video is playing).

Hmm. Weird. I have that enabled. I tried both with it enabled and disabled and have the same jerky video during camera pans.

Deinterlacing probably won’t affect camera panning much, it will simply eliminate the double (blurred) lines that appear with interlaced content.

You might try disabling deinterlacing to see if that changes anything for you. Also, the new Apple TV 4K will handle high-bitrate 1080i content much better.

I just got a new Apple TV 4K this morning and it made not difference. I will give it a try without deinterlacing on the Apple TV 4K. I would love to run all my videos through Infuse because I love the interface, but if anything, I can run these videos that are jerky through MrMC which seems to play them fine on both my old Apple TV 4 and new Apple TV 4K.

Hmm, if you’re seeing the issue on the Apple TV 4K this may be something we need to look into.

If you’re in the mood to upload a sample we can review it here to see if provides any clues.

Thanks James, I really appreciate your prompt replies and help! I uploaded a 30 second section of the show that exhibits the jerky behavior. The name of the file is jerky-interlace-sample.ts.