Default tracks are not being played correctly

I’ve just switched from my old HDX-1000 (Popcorn Hour) NMT to ATV4 and Infuse.

From my short time with Infuse I’m noticing it’s not honoring the default track on media files. Infuse is set to “auto” on audio and subtiles and it’s both DVDs and MKVs I’m seeing it. Audio or subtitle tracks that have the default flag is being ignored. I prefer to have the media file decide which track should be played hence the default track choice.

I have some movies with both English and non-English audio. The non-English audio track is to default but when playing in Infuse it’ll be the English track that’s being played. Also I have files with subtitles that has the forced flag set and it’s also being ignored.

It seems Infuse is just picking up the first track of audio and subtitle it sees.

Anybody else experiencing this and any way to go about it? I really don’t want to set a specific language in the audio and subtitles settings if I can avoid it.

Infuse will honor the default audio track if its set.

If possible, can you run one of the files through MediaInfo and attach the specs?

MediaInfo is a free download available at the links below.



Thanks James, I’ve set everything to “auto” in both the Apple TV and also Infuse. It seems to have solved the issue. :slight_smile:

Ah yes, in some cases audio output settings can affect which track is selected.

Glad you got it figured out. :slight_smile: