Deep Link Support

I’ve been talking with a great third party Trakt iOS App developer about being able to launch TV show episodes from his app. Neither of us knew if Infuse had deep link support to make a feature like this possible.
Does anyone know if this is something that’s currently possible?

1 Like

+1 for this request

+1 for this feature as well - it would support creating Siri shortcuts

Movies on iOS do show up in spotlight search. Maybe that can be leveraged?

Is it technically possible for third-party Trakt apps launch movies or tv show episodes that exist in Infuse?

Recently I’ve found an AppleTV app called “TvOS deeplinks”, which let you use deep linking on AppleTv, whatever deep link you want to execute you just send it to the app. I’ve tried it briefly and it has a huge potential.

I even tried with “infuse://“ and it opens it, so if there was a deep linking feature standard within infuse we could automate a lot of stuff.

For example create a shortcut and tell Siri something like “Siri play on infuse next episode of Cheers” and it will generate a link something like infuse://series/Cheers/nextepisode being “series” and “nextepisode” reserved words from the deep linking feature. It would be awesome.

Also if this won’t make it to wishlist it could be nice to understand how the existing deep linking features work like when we open a specific serie or episode from the top shelf menu on ATV

Hello everyone,

I would like to post a message on your forum because I am stuck on something, I will explain:

I have a jellyfin server that I use for my films and series, I also use home assistant to control my apple tv, I can send a YouTube video via a URL to launch a video.

My question is the following, how can I retrieve the link that will allow me to launch a film or series via infuse which is installed on my apple tv.

I found someone on the internet who tried this command: infuse://series/Cheers

when I do that it launches the infuse application on the Apple TV but I get this message “Failed to open input stream in demuxing stream”

I obviously tried to replace the “cheers” series with one of the series that is available on my infuse app but to no avail it launches the app but it gives me the error message that I gave you.

I’m not yet in the pro version, but if I find a solution for my current problem I will take the pro version without any problem.

Thanks in advance to anyone who can help me. I specify that I do not have a huge level of knowledge in the field of your infuse app