Cyberduck only sees 2000 files when FTP to AppleTV

When FTPing to a USB drive on my AppleTV it works great, except I only see 2000 files.  I've tried this for the past several weeks and although I can transfer more than 2000 files, and find them on my USB drive from within Nito or XBMC, Cyberduck only shows me the first 2000 files on the drive.  I'm using Cyberduck 3.8.1.   Has anyone else ever seen this?

You could try Transmit (I think they have a trial period):

http://www.panic.com/transmit/

another free client that does ftp/sftp/ftps is filezilla for mac (also free like cyberduck...):

http://downloads.sourceforge.net/filezilla/FileZilla_3.3.5.1_i686-apple-darwin9.app.tar.bz2 (requires 10.5+, older versions at http://sourceforge.net/projects/filezilla/files/FileZilla_Client/)

I'm curious to see if these other clients experience the same "cutoff"

K

I'm also interested to see whether an alternate FTP client resolves the issue.

[moving this to the USB drive section]

Has anyone found a way around this issue?

I just tried again with Cyberduck version 4.0.1 and get the same cut-off with FTP.

Here's the message it states "226 Output truncated to 2000 matches"

If I use SFTP, it works fine, with no truncation.  I can see all my files, however, SFTP is slower than FTP.

 

Peter