Cyberduck FTP Connection Failure

After successfully transferring ripped DVDs from my MacBook Pro to my ATV via ethernet last week, I started to transfer additional DVDs when I encountered an error part way thru the transfer. (I have not upgraded to ATV 3.0 or the latest aTV Flash yet.) I get the following error from Cyberduck:
“The last action could not be completed due to the following errors:
I/O Error: Connection failed
Unexpected null reply received”
I have reset the ATV several times, ran the Smart Installer again, restarted the laptop, and still have connection failures. I changed the Ethernet cable, disconnected the Ethernet and reactivated the wireless Airport, and still get the connection failure. I am using ftp in Cyberduck (Version 3.3b4 (5455)), Server: AppleTV.local, Port 21, username: frontrow, Password: frontrow. It worked last week and started to work tonight before the failure.
Any suggestions?

Oh well, I guess that the new ATV and aTV Flash updates demand the forum attention they deserve.

I think I’ll just update the ATV and aTV Flash and see what happens. (Crossing my fingers!)

You may try using the AppleTV IP address in place of ‘AppleTV.local’

This can be viewed on the AppleTV in the Settings > General > Network menu.

I get a weird error, too.
Apple TV on the latest version as of 11/5.
atf on the latest version as of 11/4.

I CAN upload avi’s, etc via Cyberduck no problem.
When I try and ftp TS folders, I get an error: “no such file or directory”

Anyone else see this?

Still have problems. I have updated AppleTV to 3.0 and installed aTV Flash 4.0.
I was able to upload some ripped DVDs but now experiencing the same problems. Most times I cannot connect to the ATV. Other times, I can connect but was not able to upload the ripped DVDs. I have tried deleting Cyberduck and downloading a fresh copy as well as restarting my computer as well as the Apple TV. None of these worked. I can sync the ATV with iTunes via Ethernet with no problem, so I do not believe it is a hardware problem. (I also ran the ATV diagnostics to verify all is ok.) I have also tried substituting “AppleTV.local” with the ATV IP address “DHCP” without success. I’m using a Mac running 10.6.1 (Snow Leopard) and Cyberduck 3.3b4 (5455).
Any suggestions?
Is there another way to transfer ripped DVDs to the external hard drive attached to the ATV set up as “external”? Is there a way to connect the external hard drive directly to my computer to bypass ATV?

I tried using SFTP (SSH File Transfer Protocol) in Cyberduck. I’m able to connect with the Apple TV but when I try to add a ripped DVD to the Movies folder, I get the following error message:

No such file (SSH_FX_NO_SUCH_FILE: A reference was made to a file which does not exist.).

Does this help anyone determine what the problem is?

I have the same problem. Cyberduck won’t connect. I/O Connection failure. I’ve tried using the AppleTV IP address as well, but no luck.

I don’t remember exactly how I found out, it might have been somewhere along the line when I was upgrading to 3.0.1 & aTV Flash 4.0.1., but the reason for my FTP error is that my internal ATV drive was full! All along I thought I was transferring to the external drive but instead I was transferring ripped DVDs to the internal drive! I think I now have it straightened out as far as FTP issues but I have other issues as described in my “Ripped DVDs Onto External Primary Storage HD” post.

I think the aTV guys are really smart but what is second nature to them is totally foreign to most of us. They need to get someone off the street (like me), sit them down, and watch and listen while they try to follow their instructions. Their instructions need to be more detailed, yet simple. Detailed to the point of doing EXACTLY “this”, and just as important, don’t do “that”.

Perhaps this was the issue. I was unknowingly transferring to the internal drive instead of the external. Why doesn’t it just say “drive full”? It would have saved me headaches.

How does one know how much space is being used on the internal drive if the external drive is used as the primary drive? iTunes shows me space used and available for the external/primary, but I don’t know how to determine space used on the internal/ATV.

Anyway, I’ve successfully transferred (FTP) two DVDs using Cyberduck to my external/primary drive with only one error on the first transfer (I/O Error, Upload failed, the connection is being shut down), but when I clicked retry, it finished the upload. Both movies play fine on the ATV. So I guess I my internal is full. That would explain why it worked the first few times then outright quit. For one movie, it would complete 67% every time, then fail. I would usually delete these failed transfers. Drove me nuts. It’s working on a third now. It takes 6-12 hours to transfer one movie. Is that normal? Is there a way to speed that up?

I put these two external transfers on /mnt/Scratch/Volumes/MediaHD/External Media. I did not create that folder or path on the ATV; it was there after the ATVFlash installation. If I understand ednet in “Ripped DVDs Onto External Primary Storage HD” post, a “Movies” folder was created or something like that and it wasn’t working. Try the External Media folder and hopefully you’ll see it under NitoTV/Files on the ATV.


One thing to keep in mind. It sounds like you are connecting to the AppleTV via SFTP, this will work but your transfers will take a LONG time to complete. Using FTP, and locating the ‘External Media’ folder inside the Movies folder will achieve the same result, but reduce your transfer times substantially.

Now I’m not so sure the problem is a full internal ATV. The fail or success variable seems to be SFTP vs. FTP.

Using FTP, the transfer immediately begins to fail. This happens if I drop the title into the Movies folder or the External Media folder inside the Movies folder, as suggested. The errors are “upload failed” and “cannot create folder”, then FTP error upload failed /movies/external media/movie title/common/default.htm, can’t open that file: permission denied rename/move failure: no such file or directory.

Using FTP, I can’t locate the Volumes folder.

Using SFTP, I can find /Volumes/Media HD/External Media, drop the movie there and it works, but it does take a very long time.

What am I doing wrong with FTP? Where’s the volumes folder?

2 things. First, the actuall question/problem for this original post. this is what I get too, transfering iso files to apple tv. Can't open that file: Permission denied Rename/move failure: No such file or directory.

This is not a full harddrive issue. This is something different. I can copy the iso to other internal harddrives on my network, but not to the apple tv. and its only iso files....avi , mp4 files transfer fine. so we need an answer???????also, I tried to stream the iso file from a network drive, not a chance. choppy as hell. So I wanted to put on internal drive, should make sense to do this... but no luck??????


second thing, the last guyasked, how to transfer via website. well this is kinda the wrong place for asking that, but. if you are using your home computor as your website, thats easy, just dedicated a harddrive or section of a harddrive for the ftp and give people access with the correct ip address, username and password.... simple. if you have a website else were. this will be a bit more dificult. good luck


Lets make sure we find an answer to this ISO transfer problem. Please. Thank you!