Custom firmware will not install on the Apple TV

So I followed the instructions on how to create a custom firmware to use on the Apple TV. I even got as far as getting the Pwnage Tool to open iTunes to restore the device. The process comes to a stop during the restore when I get a message that says the firmware is not compatible with the Apple TV. What, if anything, am I doing wrong? I am running the latest version of iTunes and it did download the latest version of the firmware to create the custom firmware with. Thanks.

Same here, Pwnage creates the custom firmware, with the AppleTV in DFU mode in iTunes I select the IPSW and iTunes tries to verify the restore and fails saying its not suitable for the device.

same here.

pwn group didn´t release yet software for 4.2.1 apple tv update, we need to wait with jailbreaking, this atv beta version is actual just for users with factory apple tv firmware (4.0 or 4.1)

Thanks thats what I just discovered, I'm running 4.1 did try limera1n but this has worked either.

i just noticed that as well. I ran the firmware restore in iTunes just to see what file it would download from the server and sure enough, it was a different file than the one Pwnage Tool downloaded. Hopefully, they will update this soon.

The problem is that this beta only works with 4.1. There is no jailbreak yet for 4.2.1. Compunding the issues is if you did NOT jailbreak your ATV when it was 4.1 and saved your SHSH blobs with Tiny Umbrella, there is no way to go back to 4.1, Apple is not activating restores with 4.1 anymore.


Bad timing on this beta release since most of us went to 4.2.1 to try out Airplay.

The file itunes download for me was: AppleTV2,1_4.1_8M89_Restore

But I still got the same problem, restoring the new customised firmware give me errors.


any clue?



last week, when appletv started to ask you if you wanted to update, did you? if so, you are SOL until the dev team releases a pwnage tool for 4.2.1. sorry, i dont think firecore knew very much about "jailbreaking" since this is the first device they had to do it on. but, i am sure all will be fixed soon.


if you did NOT accept the update, and you are still on 4.0, or 4.1 ipsw. then try restoring the same way you did to the custom FW, but navigate to library>itunes>appletv software updates> and select the ORIGINAL 4.1 FW, not the new one!!! (although, you may not have it, unless you download it yourself) i was having problems restoring to a JBed FW, from a JBed FW (i needed to because the package would not find my appletv). i had to restore to a stock FW, then re-build the custom one, put it into DFU, and then restore to the custom one. once i did all of that, everything went smoothly.

I got version 4.1 installed as seen on about section of the ATV2.

If I click update on the ATV2 it says my software is up to date.


Didn't work for me either

then yes, you have to wait. on you atv it says 4.1, but it in actually 4.2.1 for the ipsw file. sorry...

No worries anyway the ATV Flash is in beta and it doesn't has the streaming avi film feature that I need so I could wait.

Just wonder if it will also read subtitles from .srt files

PLEX does stream avis, but i dont know about the subs.

But I still have to jailbreak the ATV2 to install PLEX I suppose


This makes me so sad  :(… i thought i was going to get to play today and i cant. ARRRRRRRGGGGGG! Lame, haha

In summary it sounds like anybody that has 4.2 will need to wait for pwnage to update?  Will that be noted anytime on the Firecore updates/news?

I have exact problem as above.