custom firmware restore in itunes during jailbreak gives error 21

Hi

 

I am using the latest seas0npass for windows to jailbreak my ATV2. After the custom firmware was created, the restore in itunes fails and gives error 21. With ATV stuck in DFU mode, i had to use normal restore from itunes.

 

Itunes downloaded the latest version and restored the ATV. I once again tried to jailbreak, but again on restoring custome firmware itunes gives error 21.

 

Pls advise, how i can jailbreak?

 

Vibhor

i noticed that the error 21 is coming from the reason that it fails to verify the file from apple. when i do a normal restore using standard firmware, it works perfectly well :frowning:

Same error 21 here to. Restored with the Itunes using the restore file seas0npass downloaded from apple no problem anyone have idea how to correct.  

Tried again ran seas0npass it seen firmware it downloaded before then made custom over writing one from before.

Only thing did diff was put atv2 into DFU mode before started then just let seas0npass do its thing then did the restore with itunes.

The installed atvflash All is well now.

Same works for me…

Do an normal update of your atv2 with seas0npass… When the question comes, use itunes to restore, choose no.
Start ireb4 to place the atv2 in dfu. When ireb4 has run succesfull, leave it open, start itunes, left-shift click on restore and select the dmg file that Seas0npass have generated. 

The above worked for me on both my apple TV2’s.

 

I would strongly recomment that users who are having problems with restoring use iReb4 (without iTunes runng) to ensure that they have got their ATV2 into DFU mode.   Using ireb4 both helps you get into DFU mode (by following its instructions), and gives you confirmation when you have succeeded.

I dont see iReb4 for Mac when i go to iH8sn0w’s site, any suggestions? Does FireCore have a fix for this?

I followed cyberbob’s instruction but still get error 21.

I updated Appletv to new software from within menu system for the Vimeo access.

Got newest Seas0npass - ran it all ok - have custom ipsw.

Used iReb to force pwned DFU mode - worked ok.

Started up itunes. shift left click Restore. Select ipsw from Seas0npass.

Then I either get error 21 OR itunes recognises my Appletv as an iphone and thus won’t let me restore using the custom ipsw as its “incompatible.”

Help :frowning:

 

 

EDIT: all fixed, I restored to 4.2.2 and tried again - all worked fine, now JB 4.3 loaded. Seems that trying to JB after installing the latest update from Apple was screwing it up.