Custom firmware can't be restored

Hi,

it seems that Seas0nPass successfully created the custom firmware ipsw for my ATV.

But although ATV is in DFU mode it isn't being recognized by Seas0nPass. So I tried to manually restore the resulting ipsw in iTunes but this resulted in error 21 on my MacBook and error 1600 on my MacBook Pro.

If I manually restore the original 4.2.1 it works without any problems. 

Do you have any idea what could have went wrong? It must have something todo with the custom firmware created by Seas0nPass. Or something with iTunes requesting some stuff from Apple's server (I think I saw a status message during the restore that mentioned something like that).

I couldn't find similar problems posted by other users on the Internet. Is it just me having this problem?

Thanks for your help

Tom

Which version of Seas0nPass are you using?

We have a few ideas for improving the reliability of the restore process and will probably have another update available soon.

Thanks for your fast reply.

I am using the current Seas0nPass 0.6.6 (15). Moreover I am using the current version of iTunes 10.1.1 (4) and Mac OS 10.6.6

But although the automatic restore doesn't work I guess the something is wrong with the ipsw. Am I right?

 

same prob with same config to me.. i rather guess, the itunes config script isn´t right ?! is there a chance to test it with an older version seas0npass???

same problem here... error on imac. apple tv black latest update (system restore) and imac fully updated...

 

iTunes restore script failed! Select IPSW in Finder...

when i double click on IPSW in finder he doesn't do anything :(

Same problem.

I've tried the custom restore in itunes, pressing option (alt) + click in restore and choosing the ipsw file. However, after about 10 minutes itunes said that it cannot be restored. Now, I have another error when I try to restore manually.

Any idea?

Same problem. Similar specs (SeasonPass .6.6 (15), iTunes 10.1.1 (4), Mac OS X 10.6.6). iTunes does not select the update automatically. After I select the SeasonPass created IPSW file iTunes gives error 21.

 

Looking forward to the advice so I can get my copy of aTV Flash (black).

 

 

BR

AK

Same problem. Similar specs (SeasonPass .6.6 (15), iTunes 10.1.1 (4), Mac OS X 10.6.6). iTunes does not select the update automatically. After I select the SeasonPass created IPSW file iTunes gives error 21.

 

Looking forward to the advice so I can get my copy of aTV Flash (black).

 

 

BR

AK

Same problem for me, i've sent my SP_Debug.log to Firecore. Hopefully they can find what's wrong. I'm really looking forward to aTV Flash on my Apple TV! 

 

//Stefan

Same here

I've read on other forums that there seems to be a problem with Seas0nPass and MacBook Pro's. iMacs seems to work.. 

 

//Stefan

Good to hear that others have the same problem. I thought it's just me.

Anyways, if you guys from firecore need some logs, traces or other support from my side, please tell me. I think it's great from you guys to offer this JB tool for free and I want to support you where I can. Of course I am going to buy the other packages with Plex, etc. from you.

glad reading this, I am not the only one, same problems on my side. bought atvflash yesterday to improve my new atv 2G but after some hours of trying I gave up.

finally I've got an atv that always let me know (when plugged) that it want to be connected to itunes. nothing work, neither if I manually restore original 4.2.1 nor the custom ISPW file. 

please let me know If this knows problem can be fixed.

regards

Dirk

i also cannot restore the custom firmware. it gives me error 1600 or 1601 after trying to verify with apple (the script gets this far automatically). i have tried with a mac pro, mac book pro and an imac. this is getting frustrating and i'm now regretting purchasing atv flash before attempting to jailbreak...

Seems that version 0.6.7 again isn't working for me. The restore-process isn't initiated and if I restore manually in iTunes I get the same error (21) :-(

Same thing when trying to restore iTunes, the downloaded file are there, but does anyone knows how to do the restore manually? Ideas will be very welcome! Thank you!

Hi Max, is there another way to JB the Apple TV black so I may be able to install the ATV Flash (beta)? Or it has to be done through IPSW? Thank you.

Same problem here, I've tried different ways but not success.

Help!!

@davidc.7170

Just hold down your ALT-key while clicking on the restore-button within iTunes. Then you are able to select your customized firmware (ipsw-file).

Have luck!

Hello All,

I was getting error 21, error 1600, and error 1601. But I finally got it working.  For me it was a two-pronged issue. 

Error 21 points to bad cable, or bad ipsw.   

First, let Seas0npass create the custom firmware, but don't worry about it automatically restoring with it's scripts, they failed everytime for me.  After I had the custom firmware created, I placed it on my desktop.  I then unplugged and replugged my atv2 back in, and let itunes recognize it.  I then performed a FRESH restore with the official apple ipsw.  

Once it's done it will say plug into tv.  Unplug it from your machine, wait 5 seconds or so and plug it back in.  itunes should recognize it again, then search and manually restore to the custom firmware.  I've done it a few times now, and if I don't follow this process I get error 21.  fresh restore then custom.  

you may need to put the atv2 into DFU mode right before you do the custom firmware (plug in wait 5 seconds till light starts flashing rapidly, then menu and play for 7-10secs.).  i've been able to do it NOT in DFU mode a couple times, just right after a fresh restore.  another couple times I had to have it in DFU mode right before the custom restore. odd, but i promise I've done it both ways... following the process of fresh official restore, then custom back-to-back has solved my 21, 1600, 1601 errors.

If this still doesn't work and the custom restore starts but fails after ~5-10% with error 21 it might be your cable.  i had this issue as well. I was trying to restore the custom firmware, it would get maybe 5-10% and fail, error 21.  I decided to use another cable (oddly enough a Blackberry micro to usb) and it worked. so it might be your cable, try another cable.  I purchased one online, and it's a pos, I can get it to work everytime with the BB cable, but not with the one I purchased on Amazon.

I've done all the restoring in a OSX VM via Win 7, so I'm positive those with a macbook should have fewer issues and this should resolve your error 21. i've then been thetherbooting in windows via tetheredboot utility. (see tether boot issues post).

try a new cable, and try the back-to-back restores with the offical and then the custom.