Custom Collections broken after files moved

Hi

I have Infuse Pro 7.7.2 and primary use is watching via AppleTV (latest 4K, latest OS update) with as files source a QNAP NAS. Everything had been working well, I created 18 custom collections.

Then I consolidated my two movie folders into one on the QNAP. While files play perfectly on their own or from within smart collections, for all files that were moved I can no longer play them from within a custom collection. I get the “An Error Occurred. Failed to open input stream in denuding stream”. Files that were not moved still play fine from within custom collections. Files that were moved still play fine from anywhere other than a custom collection.

No matter how many refreshes or ‘check for changes’ I run within the Infuse app or after rebooting the AppleTV it’s still broken. Again the files are ok as they play fine from other areas in the app.

I understood that Custom Collections, like other collections, can deal with files being moved? It seems not, at least on AppleTV.

Anyway after creating those 18 custom collections, I’d rather not have to do it all again. Is there a fast fix for these broken links?

Diagnostic code VJX58

Thanks

Bruce

Sent this in 5 days ago, no reply here or via the support email I sent. Disappointed Pro subscriber.

Placing this here as previous post in the metadata section 5 days ago got no response.

Hi

I have Infuse Pro 7.7.2 and primary use is watching via AppleTV (latest 4K, latest OS update) with as files source a QNAP NAS. Everything had been working well, I created 18 custom collections.

Then I consolidated my two movie folders into one on the QNAP. While files play perfectly on their own or from within smart collections, for all files that were moved I can no longer play them from within a custom collection. I get the “An Error Occurred. Failed to open input stream in denuding stream”. Files that were not moved still play fine from within custom collections. Files that were moved still play fine from anywhere other than a custom collection.

No matter how many refreshes or ‘check for changes’ I run within the Infuse app or after rebooting the AppleTV it’s still broken. Again the files are ok as they play fine from other areas in the app.

I understood that Custom Collections, like other collections, can deal with files being moved? It seems not, at least on AppleTV.

Anyway after creating those 18 custom collections, I’d rather not have to do it all again. Is there a fast fix for these broken links?

Diagnostic code VJX58

Thanks

Bruce

When you add items to playlists or custom collections, I believe it adds a link to the exact file path. So if you rename, remove, or move the files, that link is now broken. It doesn’t automatically update as you are expecting.

Part of the reasoning for this is so that if you have multiple versions of a video, like theatrical versus special edition, you can make a playlist or collection of just those specific ones and it doesn’t automatically group them together. In this case, I can’t just go off the name of the film.

1 Like

That would be a shame, as Firecore in their support pages for Infuse say the opposite, that Custom Collections are smart enough to survive files moving, which it seems may not be true.

The support page doesn’t explicitly say that Custom Collections work that way, just “Collections”. So I guess @james better clarify. It could be a bug or the documentation needs to be updated.