Cropping issue with some TVs

With the option disabled, DoVi files will play in HDR (instead of DoVi).

Since DoVi is not supported on Samsung TVs the Apple TV shouldn’t ever be switching to this mode, but it seems in some cases this may still be happening which leads to unexpected results. Since mode switching is handled by the system, I don’t believe this is something we have much control over, and may be due to a variety of factors, such as: HDMI cable, AV receiver, or other devices that may be connected which are reporting as Dolby Vision compatible.

So far I’ve not been able to replicate this when playing DoVi files (include those with cropped black bars) on 3 different Sonys, 2 Samsungs, and 2 LGs so it’s hard to say exactly what is going on.

I’ve noticed that the black bars on some content overlays menus & system dialogs such as the Infuse top sliding menu or AirPods system notification/dialog.

Occurs on Apple TV with Infuse version 7.5.2 (4410).

At this moment I can not upload images (“Sorry, an error has occurred.”) to this post but I’ll try again later and attach some examples. Images embedded via Imgur.

Image 1: AirPods system dialog

Image 2: Playback menu

Does disabling the ‘Extended Dolby Vision’ setting in Infuse > Settings > Playback make a difference?

Yes, that resolved the issue. Whats does „Extended Dolby Vision“ actually mean?

I moved your post to a currently running thread discussing this issue. The other question is do you have a Samsung TV?

There’s a post above that goes into some detail.

1 Like

Hi, tried mentioned settings in this thread but sadly did not work on Samsung UE43NU6025.

It would help if you could show a pic of what you’re seeing and what you mean by not working.

Sorry I meant “ disabling the ‘Extended Dolby Vision’ setting in Infuse “

If you’re seeing this on all videos you may want to check here

Sadly dont seem to be any settings in the tv to fix it, i have tried everything.

Just the dv file types that this happens to, rest works without problems.

Can you do a screen cap with the 'Extended Dolby Vision" setting disabled in Infuse?

Other formats that are not dv shows normal like this:

This seems to be an issue with some Samsung TVs when playing DoVi content. It seems like the Apple TV may be trying to switch to DoVi mode, even though the TV does not support this.

I haven’t been able to replicate this here on 2 different Samsung models, but here are a few things you can try.

  1. Reset the Apple TV’s video settings, and re-enable the Match Content options
  2. Set the Apple TV video output mode to HDR (or SDR) and disable the Match Dynamic Range option
  3. Adjust HDMI port settings (I believe the would be listed under ‘HDMI UHD Color’ in the TV settings)
  4. Try a different HDMI port or HDMI cable

Did try back and forward, SDR seem to be the way to go even with Match Dynamic Range enabled it works without problem.

2 Likes

Hi there,
Since about 1 month, I’m experiencing an anoying bug that never happened before.
On some movies, not all, the infuse HUD is hidden by the black borders of the movie ( where we can select subtitle / audio tracks, or the timeline at the bottom ).

You can check that here, and enjoy my son’s lullaby :rofl:

I don’t know if this is a TvOS issue or Infuse, but it’s really annoying, especially when I want subtitles, which are hidden too, so I have to manage a custom vertical alignment as workaround.

Is that a known issue?

Thank you

Does disabling the ‘Extended Dolby Vision’ setting in Infuse > Settings > Playback make a difference?

I went ahead and moved your post to a currently thread discussing this issue.

3 Likes

Hey NCB, thank you for the quick reply as usual.
Yes it fixed the issue ! Sorry I didn’t know there already were a topic on that.
I supposed that DV was involved, but after trying an other movie with DV with no issue, I thought I was wrong.
Let me know if you are interested about it.

Thank you again :+1:t2::+1:t2::+1:t2:

2 Likes

This solved it for me too. God a love how even when things are broken, there is already a fix with infuse.

Sorry for necroing this topic, but the issues still persists on my television.
I have an LG C7 television and this only happens with DV mkv files. I play them on my AppleTV.
I have the same issue as the other people in this topic.

Things I have tried (after reading this topic):

  • Reset Apple TV’s video settings and re-enabled Match Content
  • Disabled the ‘Extended Dolby Vision’ in the Infuse App.

This doesn’t seem to help. Rather annoying, now I can’t read my subtitles. Any suggestions?

Can you run one of the videos that you’re having issues with through mediainfo and post the results here?