Crashing w/ MEGA share added

App worked fine yesterday. Today I updated to 7.5. Now everytime I open the app it crashes after a few seconds. Tried deleting and re-downloading, didn’t work.

iPad is up to date: iPadOS 16.3.1
Infuse 7.5, connected to mega.

Any ideas what to do? Other than going back to VLC? :grinning:

First thing to try is to restart the ipad and see if that helps.

Did that too of course. Thought that was common sense and didn’t even write it in the first post. :joy:

Isn’t always common any more. :wink:

Are you deleting the app or off loading it?

1 Like

I deleted the app. Don’t know what offloading is and how that’s done…

If you have enough time before the crash, could you try launching it, go to settings and turn off metadata fetching?

After a couple of attempts, managed to turn the metadata fetching off. App continues to crash all the time.

Okay, one other test, right after launching, go to the library settings screen where you see the number of movies, tv shows, and other and below that there are messages telling what process Infuse is doing. If you can go there and see what message is displaying when it crashes?

“Your files are being processed. They will appear here in a moment.”

The last race to run is to launch Infuse and then go right to submit diagnostics and get the 5 digit code and post it here. That may help the Devs figure out what’s happening.

Sorry I couldn’t figure it out for ya but the devs are responsive.

It crashes so fast I can’t get to the contact us section. :weary:

Got one.

Diagnostics: Z8VM2

Managed to remove the link to Mega. App stopped crashing and now I’m watching a show which is downloaded on my iPad.
Took a break of watching the show, tried to add Mega again, the app crashed again. So the problem seems to be in the link between Infuse and Mega. If that helps anyone.

There were a couple others having crashes with Mega as well @NC_Bullseye can you merge them?

Going to wait till we figure out if it’s mega or something else. Some were having crashes and not using mega. (me for one) and I’ll keep an eye on this till we figure out if it’s the same problem or not.

1 Like

Looking into this…

1 Like

This appears to be a general crash related to the MEGA service/SDK, as it is also happening with 7.4.10 (an update that was released in December).

We’re currently using a fairly recent version of the MEGA SDK, but will be updating to the newest version to see if this helps. We should have something to test within the next few days.


Same thing is happening to me, super down about as I can’t watch anything and actually have to hold a conversation with my wife now. Forgot how annoying she is.

I can’t even disconnect the Mega connection as it crashes quickly.

Hey James, Infuse is still not showing up under TestFlight for me.

There are no changes for this to test yet, but hopefully very soon.