Could not open dir [smb://...]. Reason: Permision denied (13)

Hallo.

I just installed aTV Flash (black) 1.0 and all is ok (jailbreak with Seas0nPass), with one exception:

  • I configured a SMB share, using an usb pen attached to my belkin n+ wireless router
  • the connection test was ok
  • when I try to access to the share I can select the volume corresponding to the usb pen...
  • ...but when I select it, I get the error in subject.

The SMB share is accessible from my macbook pro without any username and password. AFP shares are ok.

Please, can you help?

Thank you in advance.

Alessandro

I have the same issue

a little bit simular problem with timecapsule. access from appletv2 to timecapsule only by timecapsule_password, without any login. access from MBP without any problem, access from appletv2: permission denied. try to provide “jone_doe” as a login ?

I have the same issue, trying to access share on windows 7. shared the specific folders as documented in the knowledge base. no joy!! this is very frustrating as I only bought apple tv to use the functionality of the watching my external movies  :frowning:

I’m in the same boat. I share all my folders the same way. I have a PC in the living which accesses the PC in the den just fine. ATV will access a few folders, but not all. Otherwise ATV Black has been awesome.

Has anyone found a fix for this?

I have the same issue … Can someone help us please… 

If you’ve set up your shares as shown on the support page, but still have the error 13 message, try this…restart the ATV by holding the Menu button and the Down direction together to a count of about 5 and then let go. I can’t take credit for this; found the info in another thread. It solved all my problems. My ATV can now access all my shared folders. Plus ISO files that previously did not play are now working in the media player. I love Flash!

Sounds like it might work, i’ll give it a try but will it break the jailbreak because its tethered?

I’m not sure about that since I’m still using the older Apple software and don’t need to do a tethered break.

I did the reset. It didn’t break the jb but it still doesn’t work. Just to add. The mac formatted files are accessible and so are the external hdd that are formatted with mac but the error only pops up on the windows hdd’s which have all my stuff on them. 

manged to move on a little further with this issue, I had to turn off the password function in the Homegroup config. I can now view my files on my external drive, However when I select the files I am still encountering the permission denied error. any help would be good.

I’m having similar problems. Installed Black no problem, I share files from my Win7 box and, while the folders show up, I can’t access files. Same permission error as above even though I have no passwords on my media files. Please help?

the problem is still not solved.

any answer from official support?

thanx

I’m getting the same error as well; I just re-jailbroke (with Seas0nPass) my ATV2 and installed aTV Flash (black) 1.1 - added the Media Player; restarted and then added my SMB shares.  2 of 4 of them work (I have 4 connections: one connected through my router Linksys E3200 [NTFS], the other through my D-Link DNS-343 [NTFS],  one to my MacBook Pro [AFS] and the other to MyBookWorld [FAT32]).  The last two will work, but not the first two.  I wonder if it is something to do with SMB or NTFS formats.

 

Looking forward to a solution.

 

Thank you,

Alex

I tried with new 1.1 version, but without success.

The AFP share from my macbook pro is ok.

The SMB share from my Belkin N+ is still not working, with the same permission error.

Is it possible to have an official answer on that?

Thank you.

Alessandro

Still no go on 1.1. Can we please have some kind of official response to this problem?

Okay, I solved the problem from my end. Here’s what you need to do:

  1. Right-click on the folder you want to share, select PROPERTIES (not Sharing/Share).

  2. Select Sharing tab, then the share button under the folder/network path.

  3. Under “Choose people to share with,” create a name called “Everyone” and assign read/write privileges.

  4. REMOVE “Homegroup” as someone you want to share with. If you don’t, you’ll get an invalid argument error instead of a permission error.

That should do it! Repeat on all folders necessary. This is for connecting to shared file space on a Windows 7 box, by the way.

Double post.

Confirmed…!!! it works when set folder share for Everyone… Thanks