Copying files from an external USB HDD to the AppleTV internal HDD

Hi,

I have an Apple TV hacked with ATVFlash... and I love it ! I use XBMC which I find really convenient (the latest Dharma Beta is a little buggy though... so I sticked to the official 9.11 release :-) 

I have hooked up an external USB Hard disk drive and it's perfectly recognized by XBMC (once the correct package has been installed !). 

But I would like to transfer files from the external USB HDD to the internal drive of the AppleTV. The XBMC interface doesn't allow me to do that ? 

 

Any ways to do this without having to connect to a computer ? Or, to do it over SSH from a computer that is remotely connected (no wires to attach but still getting acceptable transfer rates ?). 

I've tried to connect to the APpleTV using SSH. Managed to do so. I can see the internal hard drive AND the external HDD. But if I try to put files from external to internal, I get an error message "unable to rename files"... Am I doing something wrong or is this normal ? 

 

Regards.

 Hi folks,

Just answering my own question as I found out how to do it !

 

In the XBMC interface, under the "Settings" menu, appears a special feature called "Files". Just select "Files". You'll get a new window divided in two parts. On one part (i.e. the left part) just navigate to the file/folder you would like to copy/delete/move. Then press the "Menu" button for 5 or 6 seconds. A pop-up menu will appear asking you what you want to do. There, you can choose "Copy folder" or "Move folder". This will take you back to the previous window where you'll have to navigate to the place you'd like the file/folder to be copied. 

 

Nice...

 

Regards.

 

PenguinerTV

 Hi everyone,

 

Answering to myself again...

The feature that allows you to copy/move files seems to exist on XBMC. But so far I must tell that I haven't been really sucessful at using it....

 

FIRST LIMIT : 

obviously you can't copy folders, only files :-( If you want to copy the discopgraphy of an entire artist who has released 10 albums containing 10 tracks each, that's about a 100 files to move :-(

 

SECOND LIMIT : 

I tried with a large file (a 2.5Gb .mkv movie). After 10 minutes, the progress bar was still not moving. I tried to cancel : was unsuccessful. So I hard to reboot the AppleTV the hard way :-(

 

Maybe this is a bug in the AplleTV implementation of XBMC...

Maybe this is because there's a bug in the skin I'm using (Focus, alph 0.6)

Maybe this is because the files are located on a hard drive that isn't connected directly to the AppleTV, but connected to another hard drive which is then connected to the AppleTV. 

 

I'll try to investigate this further and will keep you informed. 

 

Regards.

 

PenguinerTV