Copies in favouries

The infuse Favorite “Movies” has gone strange. There are multiple copies and the same movie has different posters.


I restarted Apple TV 4K (2021 Version), no difference.
This only applies to this favourite folder, the others show correctly.

I had a similar problem Grouping duplicate movies . Apparently at this time if you have multiple copies of the same movie, infuse will not group them but show each separately. As for the different posters // metadata, it probably has to do with how you have your films named. If you want to change the metadata // posters manually, you can click on the film, click edit metadata, and manually match it to one you prefer or that is a correct match for that film… I’m definitely not an expert with infuse, but from what I’ve read and experienced that is the case, hope this helps.

There are only one copy of each movie, so that is not the issue. These are not new entries into infuse.
I don’t use this folder alot, so I can’t say when this happened. I use collections and other favourite folders and this does not appear there, only in this one folder.

oh ok ya then that’s a different problem then I was having. If you don’t have a massive collection of movies, or if you don’t mind waiting [possibly days], you can go into the settings and have it re index // refresh all metadata.

Pick one of the files you have duplicates of like the 3:10 movies and if you tap on each of the duplicates and then scroll down to the bottom of the page it should show you the actual file name and the location for it. See if there may be copies on other shares that you didn’t notice.

I would also check in Infuse > Settings > Library to see if you have multiple copies of the same share selected there.

There is only one copy of the movies. Removed movie from folder all posters for it are gone, move the movie back to folder, all return.
Below are some photo showing something I noticed.




Each one has a different category and some have different descriptions.
Only the first one matches the favourite folder for the drive where stored.

Did you see where the different posters said the file was located?

Did you check for duplicate shares?

Have you tried using the “Refresh Metadata” option in the Library settings?

Yes, checked movie locations, checked for duplicates, tried the refresh metadata. There are no duplicates.
Further checking show the the genre option shows all the extras. Don’t use this area so I didn’t know this till now.
Every other favourite folder shows the movie once. Not an issue with TV shows, only movies.
When in the movie folder, I can click on the 3:10 movie, go down to cast, choose main actor to see what other movies he is in, I see all the extras copies. If I go to my western favourite folder, repeat this, I see only one copy of the same movies.

What sort of connection do you have with your storage? Smb, nfs, ftp, plex, etc.

I set up using smb and then added plex. I checked the plex, there are no extra copies of movies.

So you have smb and plex connections at the same time or you tried both and they both had the same problem?

I checked plex to see if there was a problem there and if it carried over into infuse. Plex had no issues or extra copies like infuse does.
The problem is not everywhere in infuse, just infuse’s own movies folder and their genre folder.
All the favourite folders I have added work like they’re suppose to.

Could you provide a screen cap of the Library settings screen where you go to Settings > Library?

Is this what you wanted?

One more level down.

Click on the “Library” button you have highlighted.


There are about 2300 movies in my database, not the 6500 that is shows. Now you see how many extras I have to deal with.

Can you scroll up on that screen to see what’s next?

I may have an idea of what’s going on.

I see where your going with this, I looked down the list and found my nas drive in twice.
I unchecked the drive and everything went back to normal.
Now the cause of my nas drive in twice came from choosing to connect to plex. I use smart collections in plex, when I read that these Smart Folders worked in infuse, I connected with plex.
Guess this plex feature in not available in infuse after all.

2 Likes

Deja Vu

LOL Glad you got it sorted.

You can use Plex but use either a Plex share or one of the other protocols but not both.