"Content is currently unavailable" through network shared HDD

I am having from a month or so the following problem:
I start watching a movie from my network shared harddrvie (connected to my Airport Extreme Base usb port), and at random period of time video stops and I get error: Content is currently unavailable.
If I try to play it again sometimes it starts again, sometimes it does not. I tried to restart the player, restarted the router, but all the things seems to happen at random point. Yesterday my router even displayed error message harddrive needed repair. I connected it to diskutility then and it says all is ok. No repair needed. When I try to access the network harddrive through the macmini - everything is ok. When I try to edit the share for example from appletv infuse - it says it cannot find the drive… I think the file managment or the SMB sharing is messing something with the harddrive. Last night I played a movie it dropped again, i tried to resume playing could not, then started another movie and it run just fine.
Anybody else same problems?

I have been getting this starting a few days ago. I connect to my HDD using SFTP and it keeps failing with this message “Content is currently unavailable” same as hristokirev. Scraping the library also fails. If I add the content using DLNA then it works fine but I don’t want to use that.

I think setting the SMB mode to Legacy solved the issue… At least I don’t see the error now…

It was fine for a few days and today did it again several times… Legacy is not the solution obviously… Any ideas?

Strange thing is i installed VLC immediately and the issue was there as well… Looks like the problem is somewhere between my router and the Hard deive…