Content being removed

Hi,

been having a very strange issue as of late. Been going on for maybe 2 weeks.

I sync all my content from PUT.io over Webdav.

I have two separate folders on Put.io which I add as favourites, MOVIES and TV SHOWS.

So for the past two weeks or so my MOVIES keep disappearing from the main screen. If my TV goes into screensaver, or if I’m watching something or put infuse in the background for a couple of seconds. They just disappear, and the same couple of movies stay behind, but the rest disappear. When I go into the MOVIES (Put.io) Icon from the Favourites slider, and it loads, then all the movies come back. Also, the METADATA does not need to be re-downloaded, it’s all there. Just the movies simply disappear. And it doesn’t seem to be happening with TV shows at all.

This happens all the time. I read on one of the other forum posts that Disabling iCloud Sync would fix the issue, but it did not. I completely deleted INFUSE and all the data associated with it from my Apple TV 4K and re-downloaded and re-added the WebDav. And It synced everything, but it’s still doing it even though I disabled iCloud Sync from the fresh installation.

HELP it’s becoming really frustrating. Also, I have a 32GB Apple TV 4K, and although I cannot find a true indication of storage available, based on my app sizes and METADATA size, there’s easily more than 20GB still available. Probably 25GB.

Are these visible while browsing through the Library?

If not visible in ‘Movies’ can you check if they are listed in the ‘Other’ section?

Hi James,

only the 2 or so movies are visible both on the main screen, and in the library.

They do not show up in other either.

Also, I’m still having the issue where Infuse loses connectivity to Put.io at completely random times. I did start a forum post on this some time back. I don’t know if this is somehow related to the current issue. Nowadays I don’t have to do a soft reset to regain connectivity, simply exiting infuse (from the foreground and background) and reopening Infuse does the trick.

Can you check to ensure the favorites are selected in Settings > Library?

Unchecked items can be browsed directly via folders, but will not be indexed in the Library.

Hi James,

This is how it always was. Even before I deleted the app and reinstalled, I had the same settings.

I also redid the WebDAV connection this time from fresh.

Hi James,

A quick observation that I’ve made.

As I mentioned, only two movies get left behind when the great purge happens every now and then.

These two movies are actually TV Movies that are structurally located in my Put.io TV SHOWS folder.

So basically, my entire MOVIES folder seems to be somehow the culprit here. This folder is a little over 4TB. Maybe this information can better assist you in determining where the issue lies.

Hi James,

Scratch my last post.

When I look in Settings > Library I notice heavy variations in amount of TV Episodes synced.

So it seems to be skipping entirely the MOVIES Folder and syncing roughly 80% of TV shows. I also notice that it seems to be removing the content after the auto sync has completed.

I cannot see a pattern here.

This seems like it may be an issue with put.io.

Have you tried connecting with any other WebDAV clients to see what content is visible?

If the files become inaccessible by Infuse for whatever reason, it’s normal they would be hidden from the Library views.

Edit: We have at least one other person who is getting multiple 503 errors from put.io in their logs, so it seems it’s likely an issue on their end.

Hi James,

Thanks. I think I’ve just figured out the issue.

A while ago I noticed my Infuse was not syncing to Trakt. So I signed out and signed back into Trakt on infuse. This was about 2 weeks ago.

Anyways, I tried disabling Trakt tonight, and voila, about 80% of my movies and 80% of my tv shows were showing up when auto sync was completed.

So then I decided to try disabling Watched Indicators from Infuse settings. And then forced an auto sync.

And now 100% of all my content is showing up correctly.

I think there’s some sort of a conflict here with Trakt and Watched Indicators. And I think there’s maybe some sort of exclusions being forced into Watched Indicators even after you’ve disabled Trakt.

Personally I don’t really need Trakt. But Infuse Watched Indicators is important to me.

Please have your developers maybe look into this issue. It seems obvious that it’s Trakt starting the fire here. But unfortunately it may be under very specific conditions.