Conten not syncing across devices?

Ok, have 2 appleTV4K’s, the settings are exactly alike on both, but neither the watch history, or newly added shows up on either one. When I watch something on device a, it does not show up in the recently watched of device B. And when I add new media to my favorites that are on both devices, only device b shows the new content, device A does not. I have deleted infuse and resigned in, I have restored device to factory settings, and still not syncing across devices like it use too. Any idea’s?

It will help to know what tvOS and what version of Infuse you are using. :wink:

TVOS13, and the latest build of infuse, think it is 6.2

Infuse 6.2 or 6.2.1 or 6.2.2 ?

Are you running Pro, or just the free version?

Some syncing is limited to Pro, and a bit more info can be found here.

Been using pro going on 2 years now

What version of Infuse? For me the difference started with 6.2.2

Yes, that is the version I currently have installed, were you able to find a solution?

I’m running a test now between 4 different ATVs so as soon as I finish I’ll have a better idea which way to go. I want to give it ample time to disseminate changes in watched status so it will take a little time.

Just a quick update, first blush it appears that infuse isn’t updating the watched status just as you’re seeing. I’m running a second pass test to confirm and will let ya know. I want to be able to let James know the steps I’m going through to give him a verifiable starting point so it may take me a bit to finish the documenting.

As a side note , it does appear that syncing changes in favorites is working and also seems to be working in the background so there is still some good going on.

Also, when I add new movies they are not showing up under recently added. It seems it’s throwing them all the way to the bottom of the movie section, and not even giving them movie art. Can you confirm yours is doing this also?

A few questions…

  1. Are you using the sample Apple ID on both devices? (Settings > Users and Accounts > iCloud)
  2. Is iCloud Sync enabled on both devices (Infuse > Settings)
  3. Is the Infuse Pro logo visible in Settings on both Apple TVs?
  4. Did you set up the share separately on each device, or did the saved share from the first Apple TV sync over to the second?
  5. How are you connecting to your share? (Check in Infuse > Settings > Shares > Share Name > Edit)

yes I am using the same appleiD on both devices. yes, pro is visible on both Apple TV:s, I connected to the share separately on 2nd appleTV, and I am connected to the share via SMB. what about this is wrong? this is how I have done it up till now.

Ah, setting up the share separately on each device may be the cause here.

Currently, if you set up a share on one device Infuse will use iCloud to sync that share over to other devices. As a result, your watched history and progress will stay in sync between devices.

If you set up the shares on each device separately, Infuse will treat these as separate shares and will not sync the watched history. However, the upcoming version will allow for syncing of watched history between multiple copies of the same title, which will likely resolve this in your case.

Alternatively, you can log in to Trakt on each device to keep multiple copies of the same video in sync in the current version.

hmm, I am logged into trakTV with the same account on both. so how do I get infuse to sync the watch history as well as the recetntnly added? do I delete infuse, redownload it, and just restore purchase and log into tract, and it will do the rest?

Can you double-check to ensure you are using SMB on both devices? If so, the Recently Added should be in sync automatically (since Infuse uses the actual file dates).

If you are connecting via UPnP or DLNA, then Infuse won’t have access to the file dates.

yes both are SMB, and not only is recently added not syncing, watch history across devices isn:t either. maybe I will try removing app on 2nd appleTV, and restoring and letting it sync on it::s on by restoring purchase, and signing into trakTV

Mine seems to be finding movies and tv shows pretty well considering the tvdb issues and movies have been fine. I’m going to back out of this thread since James is working with you on it and I don’t want to confuse things with multiple problems. I sent James a truckload of info on the tests I ran here and I’m sure it will take a bit for him to decipher it. I know there’s an issue for mine since it went from working great to hobbled after software updates from both Apple and Firecore so it’s a moving target. Hang in there, it will get figured out! :slight_smile:

Ok, removed infuse, installed it again, restored pro purchase, made sure I was connected to trakTV, and iCloud syncing is on, now do I add shares manually, or let infuse pick it up from other appleTV?

Ok, it synced the share on it’s own, watch history is now showing as it should, only issue I am having now is recently added is not updating. I am signed into TrackTV, scrubler is turned on, and iCloud sync is also turned on. did I mis anything?