Connecting to SMB share (win10) with AppleTV Infuse

Hi there,

I was wondering if anyone has tips for me. Infuse has always worked well on my AppleTV, connecting to shares (SMB) on my windows 10 machine.
Now all of a sudden (it might be a beta update of TVos or update from infuse) it doesn’t work anymore. I get an error stating it’s unable to connect to my share (no specific reason or error message).

In short:

  • Switched off Icloud sync: no luck
  • Tried re-discovering the share: no luck
  • Tried connecting with different apps on the ATV (like VLC) and I can’t find another program that cannot connect to SMB shares (every other program works, except Infuse).
  • Tried deleting the cache (and 12GB of metadata) : no luck

Does anyone have an idea what I can do to fix this? (Is it for example even possible to go from beta to official TVos when the beta is already running on it)

Thanks in Advance,

Can you roll back a version in tvOS to see if that may help?

Can try, need to lookup on how to roll back. Involves a cable and itunes restore, right?

Apple TV 4 can be rolled Back but 4K cannot. If you’re still under AppleCare+ the Apple store can get you back on regular tvOS.

It’s the 4, not the 4k, and it’s no longer covered by applecare, I need to fix this one myself. Ideas?

Get a USB to USB-C cable, download the latest ipsw for tvOS (google it) and then restore using iTunes.

Gonna try that! I don’t think there’s an official update coming out anytime soon, so I don’t see many other options (I hate to see my data gone).

Before you re-install, you may just try walking through the steps to enable File Sharing on your PC.

There have been at least a few Windows updates which have caused File Sharing to become disabled, which would prevent apps like Infuse from being able to connect.

Also check to ensure the username/password you’re putting in Infuse is correct. Anonymous (guest) access gets a little weird with SMB.