Connecting to share on NAS never completes

Using Infuse 2 Pro, I’ve entered all my credentials to my NAS share.

The NAS is a Synology with multiple AFP file shares. It’s connected to the router via Ethernet. The shares are protected with user name and password. NAS is at 10.0.1.x

The error is:
An error occurred. The operation could not be completed.

The problems:

  • Infuse 2 shows its spinner trying to detect/list all shares on the network. None are shown.

  • the correct credentials are entered but the share doesn’t complete and show the share’s content.

What’s the correct format for IP address and share name?

I’m having the same problem. It originally said username and password was incorrect, then gives me the message you’re getting when I try to open a folder. It doesn’t have an edit option to verify / change user & password. How do you edit?

You can’t edit the share. Swipe right to left, and you can delete it, and then go recreate it.

Yeah, it seems that unlike the Apple TV variant of the InFuse app, the iPad / iPhone version isn’t self-discovering my local Synology NAS share on either SMB or AFP.  Had to manually enter the IP address of my share into the app to connect to my NAS share.  Bummer.

Headcase, did the login details differ significantly from my first screenshot above?

I can’t get Infuse to find my Synology NAS over UPnP and I’ve tried numerous formatting options for IP and share name - without success. Have anybody succeeded with connecting to their Synology NAS? How?

I got it working with a Synology DS-412+. Must enable SMB on the NAS, had that disalbled since I don’t use it. Seems that Infuse won’t do AFP or NFS shares, at least not from a Synology NAS.

Hi,

I have the same problem. It finds my NAS and i get to assign the login cridentials, but after that is done and i see all the folders that i have shared, when i open for example Movies or TV Shows i get the error message you get.&nbsp;<span style="color: #353535; font-family: Arial, Verdana, Tahoma, 'DejaVu Sans', sans-serif; font-size: 14px; line-height: 22px;">An error occurred. The operation could not be completed. I have a DLINK-320 NAS. Does anyone have have a solution? I cant set SMB anywhere, guess that is default or something…Really want this to work :confused:

I can confirm that enabling SMB2 on my Synology Disk Station let me connect to my NAS. AFP did not work.

I got it to work, i used my admin account for my NAS at first but then when i tried a diffrent account i created on my NAS it worked =)

Also got it to work now, but I was required to turn off the firewall on my Synology NAS to get Infuse to connect. Do anyone know what ports need to be open in order for Infuse to find and connect to the NAS? Already opened 445 and 137 for Samba…

Wow, that is odd. Infuse for Apple TV works fine on my same share running AFP only. Did you need to explictly enable SMB2 on the Syno? Wondering if it can be left deselected.

Thanks for the confirmation on your side.

Sorry for the confusion, but that’s actually expected. Infuse 2 supports SMB2 but not AFP.

As a side note, AFP seems to be getting phased out on many platforms as OS X Mavericks now defaults to SMB2 when streaming between Macs.

Hey, thanks for confirming this, James. Big thanks for making this product, too!

No problem. :slight_smile:

How does one go about enabling SMB2 on a synology NAS? I’ve searched, but no help. And Infuse 2 is still not finding my disk station, even though the app on ATV2 works fine.

Are you running DSM 4.3?

Control Panel>Win/Mac/NFS “Enable Windows file service”, "Enable SMB 2 and large MTU

Perfect! Thank you, I got it to work :slight_smile:

I’m having the same problem with my ReadyNAS Duo v1. It’s about 4 years old and supports AFP and CIFS (which I believe is SMB) but not explicitly SMB2. As a result I can connect to my NAS but it won’t allow me to move through the file structure. This also happens if I try to connect through FTP. I’ve never had this issue with any other app/program before.

Are there any plans to include UPnP or AFP in any future updates?

Also just want to add that the new update looks fantastic, you should be very proud of it James!

I had a AFP share configured on my iMac running Mavericks. I did enable SMB as was suggested in this thread. It will now see my computer. However, when I try to connect it never works.

It asks for a username. With Infuse on my ATV2 I use AFP and it is not required to enter a username. It would use the “guest” account and then access the files. Using infuse on my iPad I cannot get it to work.

Any suggestions?