Connecting CyberDuck to AppleTV

I have not setup aTV Flash on my apple TV, as I’m simply trying a few things out first. For example, I am trying to see if RipIt will actually copy my paid-for DVDs – so far, so good.

I’m now trying to use CyberDuck to connect to my AppleTV and am having a problem - getting a “connection refused” error.

For the server, I have tried using “AppleTV.local” or the ip address.

I’m not sure what username and password I should be using. I THOUGH I should use the login name for my computer and the password that I use to connect iTunes to my AppleTV.

I have even tried to get a connection using an anonymous connection, but that does not work either.

Any help is appreciated.

First you need to allow the SSH-certificate, easiest done logging in via a terminal the first time.
Then you need to use frontrow/frontrow as user/pass.

First you need to allow the SSH-certificate, easiest done logging in via a terminal the first time.

Thank you for helping…appreciate that.

Unfortunately I don’t know what you mean here. I’m using a MacPro (10,6). Can you tell me how to do this?

Thank you.

First time SSHing on *nix machines (Mac OSX, Linux, Unix etc.) you need to accept the certificate. This is easiest done using the terminal.

Open up your terminal and at the command line prompt ($), type in the following:
ssh frontrow@your.appletv.ip.address

You will be asked if you are sure you want to continue connecting (yes/no). Type yes.
You will be prompted for a password. The default password is frontrow.

After this, the certificate is stored on your client machine, and you can now login using GUI client of your choice (or continue with the terminal if you like).

Examples of applications are muCommander (OSX), GnomeCommander (Linux), WinSCP (Windows), Total Commander (Windows).

Thank you for the explanation – very clear.

When I entered the command, I got the following message:

ssh: connect to host 192.168.1.6 port 22: Connection refused

Any ideas?

Well, it sounds to me like you could have one out of 2 issues.

  1. Connectivity issues, do you have any outgoing firewall on the client machine? If so, try turning it off. Can you ping the AppleTV?
  2. Server issues, did you run the aTVFlash yet? If not, you still do not have the OpenSSH server running on your AppleTV, and can therefore not connect, since no server is listening on that port. The OpenSSH is installed as part of the aTVFlash install.

Yes I can ping AppleTV and no, I have not yet installed aTVFlash…and so I guess this is the problem.

Before purchasing the product, I wanted to check a few (what I call) choke-points. For example, will RipIT really copy my purchased DVD – it seems that it can; Can I connect to AppleTV so that I can copy my DVDs there…well, I guess I have to install aTVFlash first.

Thank you so much for your help.

There is a guide at the link below that outlines how RipIt DVD playback works.
http://wiki.atvflash.com/index.php?title=Play_DVD_Files

thank you for the reference.

deleted