Connect to QNAP (external)


I read the guides and tried kind of “everything”, but didn’t succeed…

I can connect to my QNAP NAS for example with:

Protocol: SMB
Address: KOPI-NAS.local
Username: XXX
Password: ZZZ

at home, in the same network.

if I try to connect from “outside”, I cannot connect :frowning:

tried both ways to connect - like I connect to my NAS with the QFILE-App: (on my IOS iPad Pro)

Protocol: SMB
Username: XXX
Password: ZZZ

Protocol: SMB
Address: External IP (with or without Port), for example:
Username: (Same)
Password: (Same)

Always ends with "Sorry, error occurred during connection)

Help very much appreciated…

You’ll need to open up SMB ports on your firewall. I recommend NOT doing this. It’ll open you up to all sorts of security vulnerabilities. Consider installing plex on your QNAP and using that as your remote access solution.

thank you very much for your advise and help… unfortunately my QNAP is not compatible with PLEX. (TS-221)

Any other options?

You could run plex on a desktop or laptop and have it connect to your qnap for your videos. I haven’t looked into whether it’s possible but you could also buy a raspberry pi and run plex off of that and have it connect back to your qnap

If your router has VPN server capabilities you could also connect to your VPN when away. This should let you access your qnap via SMB however this won’t work with an Apple TV as they don’t support VPN clients.


I use QNAP TS-112P via FTP and Infuse.

works with no issues :slight_smile:

thanks for your replies.

How Did you manage that?
What settings would you suggest?


I just used
Address: the IP of the NAS
port: 21
User name and password.

Hm, can’t connect.

Do I have to change any settings on my NAS?
Just verified: I have FTP activated, Port 21.

I entered my “external” IP, username, password and Foldername. No success.

You have to use the external IP of the nas.

I entered my “external” IP (as mentioned before)

You’ll need to open port 21 on your firewall and have it mapped to the internal IP of your NAS.

I have the same problem with my TS119p+. So I have 2 QNAP NAS in my network.

I open port 21 on my routeur

Entered my external IP address like xx.xx.xx.xx
User & pass

And it’s not worked …

Can you connect to it with an FTP program on a desktop? If not then you have something wrong with your settings in either your NAS or your router.