Confused: Can I apply the 1.5 update to my 4.4.4 2nd Gen atv

Pretty much what the title says.  I am running the my 2nd Gen atv (untethered) with the last version that came out before the 5.0 aTV release.   I have not upgraded my IOS version, nor do I intned to just yet. But do I understand correctly that the latest version of firecore CAN be applied safely (and presumably, I will keep my untether status)? If so, yahoo!, and hats off to firecore for maintaining code that runs on both IOS versions. Thanks,   d.          

You certainly can update to 1.5. Everything will remain as it currently is; untethered status and all.