? concerning a ATV purchase help req if poss...

Hi all,


I’ve been very lucky so far with the help of a couple of people here namely sufferinsuccotash & Carpenter940 I managed to JB my apple TV down from 6.0.2 to a tethered 5.3.


Now apart from my 8yr old who has managed to switch it off hhhmmmm. I cant wait for a untethered JB to come along… lol

On with the help…

My nephew has been asking about purchasing a 2nd hand ATV 2nd gen, but I just wanted to know… if he brought one that was on (lets say 5.0.1 or 5.0.2 - ios5) or an updated unit on ios6 - 6.0, 6.0.1, 6.1, 6.1.3, and apple are no longer signing 5.3 would I be correct in stating that he would not be able to do a JB and reverse it down to a tethered 5.3.


also if apple are still signing 5.3 how come regardless of what software i use i cannot download 5.3 blobs… (A stupid question coming up, is it at all possible to install cydia to save blobs for the unit it is installed on.) (similar to cydia on Iphone)

I have tried TinyU, the latest version and that said there was nothing available.

I tried to save with SPass and that said there was none available (if I kept on trying I would not have been able to do the JB)

and from what I can remember only Ifaith (latest version) told me of newer blobs available (inc a beta) but it did not save them.

advise, help, or any wise words would be very much appreciated, thanks chaps…


In general, any ATV2 can be jailbroken on the version it’s currently running except 6.0, 6.0.1 and 6.0.2    However, some devices running on versions 4.4.4 and 5.1.1 have been known to dump invalid blobs so be careful purchasing them unless they are already jailbroken.  Also, some devices running on versions 4.X have proven to be more difficult to jailbreak in general. 

Currently, all ATV2s can be jailbroken tethered to version 5.3 regardless of what version they are currently running.  Once Apple stops signing version 5.3, all ATV2s can still be jailbroken tethered on 4.4.2 regardless of what version they are currently running, but the process is not as simple.

So, my advice is to try purchasing an ATV2 running on version 5.0.1 or 5.0.2 or 5.1 or 5.2 and you should have no problems jailbreaking it untethered.  Or purchase one that’s already jailbroken untethered regardless of what firmware it’s running on.  

Thanks sufferinsuccotash, I shall pass on the info to my nephew, thanks very much.


a quicky to ask, but i’m in the process of installing xbmc, and after looking at a post by Carpenter940 at http://forum.firecore.com/topic/10728 I was interested in the XMBC Hub Wizard for Windows to configure my appletv, would you by any chance know if it has been taken offline, as all official links seem to be dead.

this is supposed to be it, http://xbmc-hub-wizard.googlecode.com/files/xbmchub_wizard_installer.exe was it taken down for any particular reason?





The Hub wizard program was taken down but they provided anotherway to install it. Go to this site for the instructions: http://www.xbmchub.com/blog/2012/04/24/fusion-easy-addon-installation-for-xbmc/


Thanks Carpenter940,

It’s a real problem when your a noob, having to sift through all the old stuff that still seems to be relevent, only to find out that it’s really old items.   (got totally sick at looking at all the vids on youtube, just trying to find one with some descent and uptodate info seems to be a real headache).

cheers for the reply,



oops sorry, Page bookmarked, thanks…

I’m batting about .650 on 5.0.2’s (which is NOT good) so read the threads here regarding this version and the many folks like me who have had lots of problems with this version.  

I personally would never purchase another non-jailbroken 5.0.2, and caution you when thinking of buying this version.

Well, I have read the threads, but I personally haven’t had a single problem jailbreaking any of these on 5.0.2 so it’s hard for me to believe.  I suspect people are trying to save their blobs with iFaith AFTER running SP and this is somehow causing the problem but I’m not about to try proving this.  Anyway, I’m not saying the problem doesn’t exist so you’d better scratch that one off the list too sadsack.

Thanks for the replies sufferinsuccotash & MaxieWagner, … I suppose if one was to purchase privately there wouldn’t be so much of a risk, but privately one would have to pay a premium.

Buying SecondHand is a lot lot cheaper, but the elctronics shop I frequent have a habit (or so they say) of immediately updating the firmware, thus over riding anything that was on there previously, (I suppose I was lucky with my 6.0.1).

there £130 on B grade, or £140 on A grade, madness really when the local Apple shop do the 3rd gen for £99 brand new.

Oh the joy of a JB for the 3rd Gen, I’ve seen them gathering dust in shop windows for just £50.

Thanks again chaps…

Sadsack, … Oh one other thing, I’ve installed from cydia the Nito Installer onto my iphone, but obviously there no gui, I suppose it’s the same on the Ipad as well, would it be easier doing it over wifi on a clean laptop using the PC version of Nito? … any reccomendations. I also heard a lot of people talking about a RC app to control the Atv using your phone, and that it’s available for free on the Appstore, is this the reccomended one or is there a few to choose from, (just looking to see what people have less problems with really.

really, really, appreciate all the help from here fella’s…


  I wish this was a phantom issue, Sufferin’… and I congratulate you on your good fortune.  Mine lasted for at least 10 straight 5.0.2 jailbreaks before I started batting .500 and eventually put the version on “irrevocable waivers.”  I’d like to think that my experience was solitary and random, but the evidence here suggests otherwise.  http://forum.firecore.com/topic/10501

I have literally jailbroken over 100 ATV’s in the last 6 months and have never had this issue with any other version of the software except 5.0.2.  And it’s ALWAYS 5.0.2 – for me. 

I sometimes buy these things on EBAY and as one member speculated, I might just be buying an issue that is being re-sold to me as an unsuspecting dupe.  Now THAT is my luck!

Okay, just curious…can you confirm that one of your ATVs running 5.0.2 can currently boot up non-jailbroken yet blobs are unable to be saved with ifaith?  In other words, both of these conditions exist at the same time.

Thanks for answering Maxie.  Guess ur right and I’ve just been lucky up 'til now (knock on um black plastic)

Sorry for derailing your thread there Sadsack.  For a remote control I use a free app called Sybu on my iphone which works great for keying in searches on xbmc.  Not sure it’s the best app but I kinda like it.

Absolutely!  That is exactly the case.  It’s just the darndest thing.

These Apple TV’s all work fine! Yet there is no version of Seasonpass nor of iFaith that will save their blobs.  Have tried tirelessly and endlessly… until I just had to give up and admit defeat.

I usually never worry about Seasonpass’ ability to save my signatures (on my PC)… EXCEPT when I’m attempting with a newly acquired 5.0.2.  I “white knuckle” through the process and either rejoice or (more often lately) CURSE at the conclusion. 

And, unfortunately, it seems like Seasonpass is never wrong here.  I’ve not had one instance of eventually being able to save blobs through iFaith when I have previously received the “SIGNATURES CANNOT BE SAVED” message from Seasonpass.

When Seasonpass cannot save these signatures, you’re just dead.  I would love to know that it’s just me and that there ARE solutions for these 5.0.2’s… I just haven’t found them yet…

UPDATE:  Couldn’t resist the offer of a 5.0.2 at a bargain price… and held my breath as I tried to save it’s signatures.  And what do you know?  iFaith 1.5.8 was able to do the job with the very first attmept, and the JB went flawlessly in SP.

Who can figure… but I’m definitely enjoying the uptick in my 5.0.2 batting average.