Collections - heaps of movies missing from collection - please help

I have a bit of an issue with the collections. The problem is that they dont contain the correct movies inside them. Some collections work fine but some just dont seem to “collect” all the movies inside them at all.

Examples: (Missing movies from each collection)

  • Star Wars (Episode 1, Empire strike back)
  • Star Trek: (Star Trek into darkness)
  • Indiana Jones: (indiana jones and the temple of doom)
    -back to the future (back to the future part 2)
  • Saw: ( saw 2,3,4,6, final chapter)
  • planet of the apes: (rise of the planet of the apes)
  • Captain America (captain america: the winter soldier)
  • Meet the parents: (little fockers)
  • Thor: (Thor)
  • Ocean’s Collection: (Oceans Twelve)
  • Huntsman: (Snow white and the huntsman) -****missing that movie but the collection only has 2 movies so how can it be a collection and only show 1 movie inside it?
  • Home alone (home alone 2) *****missing that movie but the collection only has 2 movies so how can it be a collection and only show 1 movie inside it?

and this happens with countless more collections. All the movie are named correctly according to themoviedb.org On top of that there are heaps of movies missing on the library (movie) section like Ted 1 and 2 but they show up on my movie (favourites) section. I have deleted the entire movie share and added it again the the same issue still happens. What else can I do?

thanks in advance for the help. I hope that the issue is clear…if not please ask me any more info.

On a separate note: All my movies show as (0) on the library overview page but they are listed under Other (718)

cheers,

Info on what Im using (latest Apple TV 4 - tvOS 10.2.1) and Infuse Pro 5.4.1

1 Like

Sorry to hear about that, it sounds like there may be an issue with Infuse fetching the correct info for these videos, which is preventing them from appearing in their respective collections.

What type of device are you streaming from?

Do you know if you are using UPnP/DLNA by chance?

Is Metadata Fetching enabled in Infuse > Settings?

Would you be able to provide an example filename of one of the affected movies?

Also, 5.4.2 was released today which might be worth trying.

Hey James, Thanks for the reply mate.

To answer your questions:

I’m using the latest Apple TV 4: Model A1625 64GB - tvOS 10.2.1
All my media is stored on a Synology NAS - DS415play with the latest OS installed DSM 6.1.1-15101

Infuse Pro 5.4.2
iCloud Sync - ON
Connected to Trakt
Scrobbler - ON
Share connected protocol is via SMB
Metadata Fetching is ON.
Embedded metadata is OFF

All movies are named according to the database on themoviedg.org site.

example:

Example of some of collections that are missing movies (there are a lot more collections that are missing movies than listed)

Iron man collection: Only shows Iron man and Iron Man 3.
files saved as: Iron Man (2008)BrRip.mp4 , Iron Man 2 (2010).1080p.BrRip.mp4 , Iron Man 3 (2013)720p.mp4

Thor collection: Only shows Thor: The Dark World
files saved as: Thor - The Dark World (2013).1080p.BluRay.mp4 and Thor (2011).1080p.BrRip.mp4

Star Wars collection: Only shows Star Wars, Return of the Jedi, Star Wars: Episode II - Attack of the Clones, Star Wars: Episode III - Revenge of the Sith, Star Wars: Force Awakens
files saved as: Star Wars - A New Hope(1977) BluRay 720p.mkv , Star Wars - Episode I - The Phantom Menace (1999) BluRay 720p.mkv, Star Wars - Episode II - Attack of the Clones (2002) BluRay 720p.mkv , Star Wars - Episode III - Revenge of the Sith (2005) BluRay 720p.mkv , Star Wars- The Force Awakens (2015).1080p.BluRay.mp4
, Return of the Jedi (1983) BluRay 720p.mkv , The Empire Strikes Back (1980) BluRay 720p.mkv

Home Alone collection: Only shows Home Alone
files saved as: Home Alone (1990).1080p.BluRay.mp4 , Home Alone 2 Lost in New York (1992).720p.BluRay.mp4

Oceans collection: Only shows Ocean’s Eleven , Ocean’s Thriteen
files saved as: Oceans Twelve (2004).720p.BrRip.mp4 , Oceans Eleven (2001).720p.BrRip.mp4 , Oceans Thirteen (2007).720p.BrRip.mp4

EXAMPLE of a 2 TRILOGIES THAT WORKS FINE:

Hobbit collection: The The Hobbit: An Unexpected Journey , The Hobbit: The Battle of the Five Armies, The Hobbit: The Desolation of Smaug
files saved as: The Hobbit - The Battle of the Five Armies (2014).1080p.BluRay.mp4 , The Hobbit - An Unexpected Journey (2012) EXTENDED.mkv , The Hobbit - The Desolation of Smaug(2013).mp4

Lord of the rings: Fellowship of the ring, 2 towers and return of the ring
files saved as: The Lord of the Rings - The Fellowship of the Ring (2001).EXTENDED.720p.BrRip.mp4 , The Lord of the Rings - The Return of the King (2003).EXTENDED.1080p.BrRip.mp4 , The Lord of the Rings - The Two Towers (2002).EXTENDED.1080p.BrRip.mp4

I also have a lot of TV shows and the they all work and show up fine on the TV show favourite and TV show Library. As for the movies they do all show up on the Movies Favorite but the ones that dont show up on the Collections also dont show up on the Movie Library either. In total I have 8947 tv episodes and 722 movies.

I hope this is enough info, if you need more, please let em know.
Thanks in advance for the help.

I have a perhaps connected problem with the collections (latest BETA installed): Two collections don’t show a cover but the movies inside the folder are correct:

  • Barbie a Mermaid tale Collection (2 movies)
  • Teenage Apocalypse Trilogy (3 movies)

So the top-folder is in both cases default grey, the text underneath correct. Barbie is taken from Time Capsule and the Teenage Trilogy from a WD MyCloud - so it doesn’t seem hardware- or protocol-related.

Could you see if the movies that are not showing up in the “Library / Movie / Collections” may be showing in the “Library / Other”?

I’ve found that the file naming can really be picky on some files in the library finding the right slot for them. I had a few movies that had a different year than what the library got from the meta data source. This was usually due to a movie that was released near the year end or start and the database called it different from the movie. Also some wanted the title to use something like “2” instead of “two” or it didn’t recognize things just right.

If they are in the “Other” section you can try to edit the metadata on each one and see if it finds it in the database. If it does it will move it to the collections folder where it belongs. I had a time with the “Aliens” collection where I had to edit metadata and search for two of them and once found in the database they moved to the right collection from the “Other” library folder.

Hope this gives you a starting place to figure out what’s going on.

What I’ve found is tha,t if they dont show up in the collections, they also dont show up on the movie library or others either. Basically the only way to get to them is to go on the my movie favourites folder…all my movies are always there.

A weird thing that I did notice…is that on the settings page where you can see a count of movies, episodes and others on the bottom left. Movies has a count of 0 and others has 722 (which is how many movies I have).

I have have gone into my movies favourites folder and done a metadata correction on every movie I have and it still has no influence on the collections.

Another weird glitch that I have noticed is that when I delete a movie from the inside infuse (by using the delete function on the movie info page (where it has the play, like, rate buttons) it wipes out all the movies on the movie library…all the movies disappear completely for a long time but eventually show up again. However I can still access them on my movie favourite section.

Hmm, something strange is definitely going on with your setup. If it’s not too much trouble you may try removing and re-installing the app to see if this helps.

Also, be sure you are leaving the Metadata Fetching option enabled, as this is required in order to use Infuse’s Library and Collections feature.

After I deleted the APP and installed it again…the collections are now working fine…so far.

Thanks for the help James.

1 Like

Great!

Let us know if any of these issues return in the future.

New addition to the same problem: “Shaft” collection - folder grey, inside everything’s showing up ok.

Does anyone here have one of those 3 faulty collections working? Then please let me know exactly how you name the files - perhaps the problem lies there (even if I doubt it…).

It looks like some collections do not yet have artwork available (Shaft Collection — The Movie Database (TMDb)).

Infuse doesn’t yet allow for overriding of collection artwork, but you could easily upload an image to TMDb for a particular collection and Infuse would be able to pick it up within a few hours. You can refresh artwork for a collection by long-pressing on the collection’s icon.

James, with “Shaft” and “Teenage Triology” you are right and will try to upload one :wink: thx for the hint.

But Barbie already has one and it is not displaying:

What could be the problem here?

I just tried it here, and it worked straight away for me.

You might try using the Refresh Artwork option (long-press on collection icon) to see if that helps.

See attached.

Refresh artwork did the trick, thx :wink:

For the other 2 I will try to find and upload some gfx.

1 Like

Added now the 2 remaining to moviedb.com and it works…

Regarding the grey folder issue…I have that on 2 tv shows of mine. Oz and the wire. the folder is grey…when you go inside of it…I can see all the seasons they all work fine and have covers for each season. The issue is with the actual show covers…this is the same issue on TV shows favourite and TV library.

Before I deleted the APP completely to sort out the issues with the collections on the start of this thread…both of these show covers worked fine.

Hmm, so even in the Library you are missing cover art?

One quick thing to try would be to use the Edit option to refresh metadata for one of the episodes in these series. This should refresh artwork for the season and series as well.

I did that and it worked for the Wire however it has not worked for Oz at all. I tried it many times and it still shows up as dark grey on the show cover…but once you into it…all seasons have their own cover correctly…weird. I have already tried a few times after the updating the APP to the newest version as well but the same issue is still happening.

Which language is your Apple TV (or Metadata option in Infuse > Settings) set to?