Clearing Cache - a necessary function

After months of no issue (and happy enjoyment of ATV Flash) I noticed that on one of my AppleTV’s, that I was unable to make a backup under Firecore’s Maintenance app -> Settings -> Manage Backups.  I would consistently get a “Backup failed!” error.  Meanwhile, my other AppleTV was fine (and they were setup identically, same version, same jailbreak, etc.)  This issue was consistent across numerous restarts.   I was concerned I’d have to do a full restore, re-jailbreak, and re-setup (which is a pain once you’ve got XBMC set up just so…) in order to fix it.  I wasn’t looking forward to it, and I couldn’t understand what was wrong/different about this AppleTV.

Anyway, I’d done a bit of research, and on a whim, decided to clear this AppleTV’s video cache files.  I did this by SSHing in and deleting the content inside these folders:

/private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental

/private/var/mobile/Library/Caches/AppleTV/Video/Other

 

Sure enough, immediately after doing this, I was able to perform a backup using Firecore’s Maintenance app.  It certainly seems to me that the problem was that my device had very little space left… these cache folders weren’t emptying automatically, and I needed to do it myself.

And so I request a feature… perhaps Maintenance app (or a new app, or a new command or a new cron job, or something) can automatically clear out these cache folders for us?Or maybe just as needed, when a backup is performed?   I’m sure this will solve issues for many folks in the future as they come across similar things.

Hmm…were you attempting a ‘Normal’ or ‘Full’ backup? Normal backups are usually under 1MB in size, whereas Full backups can grow to hundreds of MBs depending on the size of your library.

To be honest, under normal circumstances clearing the cache shouldn’t ever be required. In fact we’ve never cleared the cache on any of the Apple TVs we have here.  :wink:

I was trying Normal (as I always do) and to test, I also tried Full.  Neither worked.

 

I see in this thread (and others) that many are occasionally faced with the “running low on memory” error, and that clearing the cache invariably helps.I can’t see how adding this cleanup command to Maintenance, or maybe just to the Backup command when it fails for this reason, would be a bad thing. 

I’m trying to use CyberDuck to clear the cache and cannot gain access …

I’ve just had to do this to backup my settings prior to installing the new un-tethered 5.3 released today.

I had my backup type set to Full but the backup never completed and infact restarted the ATV (JB’d 5.0.1).

This crash/restart happened a few times. Even trying to see current backups listed showed a blank screen even though I’m sure I did a backup months ago.

 

So when I saw that the Maintenance App was requiring an update to 2.4, I updated it and tried the backup again.

 

Now, niether Normal or Full backups would even start and just reported ‘Backup Failed!’.

 

After reading this thread and deleing the cached files, the backup proceeded was successful. It is also listed in screen to restore a backup.

 

Therefore there is definitely something that needs to be done with respect to the cache and backups. Perhaps the ‘Backup’ process needs to be enhanced to ignore the cache - although I suspect a Full backup wouldn’t save the users Artwork if the cache is emptied! Or maybe more space needs to be reserved or allocated per user allowing Full backups to be successful after months of use.

 

Cheers

Mr A

I just attempted to update to the latest Maintenance version.  The update failed with an error in the log file to the effect of “…no more space.”  So I went to delete “Couch Surfer” and “Weather”.  Ironically, it gave the same error “…no more space.”  I thought that deleting something would increase space not decrease it!

So I went in and deleted the caches.  The Maintenance package updated fine and I could now delete “Couch Surfer” and “Weather”.

 

This seems to be a necessary chore for me to do once a month.  Not sure what is causing this but the cache will not even clear with a reset I have to manually go in and remove all data from the folders identified in the initial post above. 

 

Please include this as a feature in future releases. 

Same here – clearing those folders worked like a charm for a “normal” backup. I didn’t count the size of the directories before deleting, but I saw a few 3GB+ files in the first one. Never had problems with backups in the past. Latest 5.3 and Maintenance versions.

This is a forum and thread about AppleTV, not a web browser.