Choppy playback on Apple TV, smooth on iPhone

Dear Friend,

i hope my first post is under right forum.
Im more then 10years active Apple ecosystem user, but i discovered Infuse only coupe days ago. Since the app is really fantastic, im already Pro user of Infuse 6. However is the app on both platforms fantastic as i mention, the AppleTV makes me some troubles. Can you please tell me your opinion to following situation :

If i run (mostly .mkv format) FullHD movies on AppleTV with higher bitrates (2hours movies - cca 25-30GB) the picture is sadly choppy, sometimes freezes and plays again, the sound goes out of sync. The smaller, i think worse bitrate movies, and anything else runs absolutely without problems. The most interesting part is, that the same movie, from same source, same network, same place, runs on iPhone Xr absolutely without any problems ! I have maybe 3-4 movies now with cca same filesize. Itt happens on all of them.

Setup :
Apple MacMini (late2012, i5 dual-core, SSD, 5TB USB 3.0 external HDD as storage)
act as an 24/7 HomeServer for Homesharing, Homebridge, Filesharing (SMB), etc…

2x AppleTV4 (not the 4K ver!) attached to TV via HDMi, connected to Internet/LAN via WiFi

Apple Airport Extreme-TimeCapsule .ac as only device in the house managing networking

Sadly, i have now only 3.0 USB external drive as a Storage (doesnt fit till now into MacMini via SATA). The plan is to somehow attach it directly to SATA on the board or via Thunderbolt. This MacMini is connected directly to AirportExpress via cat6 LAN cable. The AppleTV 4 was till yesterday also connected directly with LAN cable to Airport (im fan of cables, instead of wireless) but i never realized, that AppleTV4 has an 100M LAN port, but .ac WiFi connection. I changed the connection to WiFi and i reached in Infuse speedtest cca 80-90M transfer speed on the storage USB drive,where also the movies are. This speed was via LAN only half of the mentioned. This change made the playback of mentioned movies lllliiitle bit smoother, but its just an detail. However, as i said, the iPhone plays with Infuse all the movies absolutely fine. Whats wrong guys please ?

Thank you very much !

Greetings

Ronald

Welcome to the forum!

First thing I’d suggest is if you can temporarily run an Ethernet cable to the ATV and try that vs WiFi.

There is a feature in Infuse where you can run a speed test on specific files and this may help determine what’s going on.
First, go to Shares in settings, under “Saved Shares” click on the share that has the problem file, scroll down to “Speed Test” and then select the file. Click on Start Test and let it run a bit. You can stop it after a minute or so if it’s a big file and then you can see what your average speed is. You can also show graph and see if you have multiple dips or problems. This is a good test to run on both your WiFi connection as well as Ethernet.

Another thing to try since you’re running the now obsoleted Airport is to go into setting in Infuse and then saved shares as above and this time after you select your share click on “Edit Share” then scroll down till you see “SMB Version” and select “Legacy” instead of “Auto” that has helped others with playback issues. If it doesn’t help you can try setting it to “SMB 2” then if no help try “SMB 1”. If none of these changes help then go ahead and reset the SMB Version back to Auto.

Edit to add: Sorry that I missed some of what you’ve already tried. Was reading on a smaller screen and missed it. :man_facepalming:

I would also be a little suspect of the differences between an A8 powered ATV vs an A12 powered phone. :wink: I can personally confirm that the ATV4K will run circles around the ATV4. I have a couple of each and it’s very obvious.

Are the files by chance also x265 compressed?

If they are VC-1 encoding or 1080i this will cause choppiness on Apple TV HD (4th gen)

Dear Friends. Thank you very much for quick reply !

I made a quick research about 2-3 movies i mention.
The compression,codecs was following :

  1. H264, bitrate 12015kbps (10GB file) 1920x1080
  2. H265 HVEC, bitrate 28527kbps (26GB file) 1920x1080

The option that AppleTV4 is “not enough” to play this files inside Infuse (without conversion to .mp4 / playing via HomeSharing) is really sad, but if its so, i cant do anything. But i think the first movie from the list should be still OK for AppleTV4, but it makes absolutely the same troubles as the second :frowning: So the truth and the solution is maybe somewhere “in the middle”.

  • i extracted both of movies with Subler from .mkv to .mp4 and added to HomeSharing. I try to run them also in the “original way”

Apple TV 4 only has A8 which does not have hardware accelerator for H265 and software decoding is slow, so you will have to expect that for 4K files and possibly some larger HD ones. There should be no problem with the HD h264 file though. Maybe post media info results on that one

1 Like

Are the h.264 videos interlaced by chance? If so, these will push the ATV4 near it’s limit and some playback issues may be seen.

One thing you can try is to disable the Deinterlacing option found in Video section of the Playback Menu (swipe down while a video is playing).

With regard to HEVC, the ATV4 will support 1080p videos up to about 20 Mbps. It looks like your videos are a bit over this at ~28 Mbps.

FWIW, there’s a pretty good chance upgrading to the ATV4K will improve playback for both file types.

Dear Friends. Thank you for your informations and reply. Im little bit confused…
I mentioned the experienced problems. Then i give a try with BLU-RAYs, BD25 and BD50 folders… Both of them are playing without any problems ! Huge files, high bitrate, and it just plays wonderful. From one side, im absolutely happy with that. From the second, it seems to be that some specific codec type/types are making troubles. Not the bitrates, not the filesize, but the codecs.

James, i check (i still have the files which made troubles) and try to switch off Deinterlacing. Thank you !

1 Like