Choppy HD video ever since aTV install

I recently installed aTV flash on my AppleTV. Install went smooth, .avi and .wmv files play fine through the “files” menu. The problem I’m having is that some of the existing movies I have in the “My Movies” section of the AppleTV are now unbelievably choppy. They are all 720p HD movies encoded in VisualHub. They all played perfectly smooth prior to the installation of the aTV flash software. I thought it might be a buffering issue as I generally stream them, so I put them directly on the AppleTV hard drive. No dice, still choppy. Does the install of the aTV software change any of the settings for playing back video through the regular AppleTV menus? If the aTV flash software essentially kills the ability for my AppleTV to play these HD movies that I have, I will be removing it and putting a charge back on my credit card for the cost of the software. Please Help.

Now I know it is using a different decoder to play the video. I now have no audio in some of the videos that played just fine before. So if someone can direct me on how to set the decoder back to the default decoder I would appreciate it greatly. I have over 150 movies in the “My Movies” section of my AppleTV. About 40 of them are HD movies that are now unwatchable, the rest are hit and miss whether the audio is there or not.

I did some more testing last night and found another interesting problem. I was messing with settings and rebooting the AppleTV using the aTV utility. Even the AppleTV startup movie was choppy. I just did a system restore/update on the software and guess what…no more choppy AppleTV startup movie and all of the 720p HD movies that wouldn’t play before now play just fine. I’ll wait until I hear if someone has a solution to this problem before giving up on the software. If someone has experienced this before and knows how to fix it I will reinstall the aTV flash software. Until then, it will rest on my iMac.

I wonder if it’s MPlayer? What do you have set to play, MPlayer, Quicktime or Both? If Mplayer only, or even if Both, you might try setting it to QuickTime only and see if it makes a difference.

Thats a good suggestion. Unfortunately I had already tried that!!! That was one of the settings I was messing with when I noticed the choppy AppleTV startup movie while rebooting. Keep the ideas coming. Hopefully its something I missed. I can’t imagine I’m the only one to have noticed this.