Choppy fullscreen playback in macOS Monterey on M1 Max

Don’t have a lot to add, other than I’m still experiencing this issue. Have been sticking to quicktime in the meantime but hoping it gets fixed soon.

Using a Mac M1 Max, I noticed this on two titles, one on UHD Blu-ray ISO and the other on BDMV. By default it plays smooth, but when using Full screen mode there playback is skipping frames.

1 Like

Just found out that restarting the computer fixes the issue

1 Like

Unfortunately that is not true. It may have worked for you by pure happenstance. Most people on this thread, including myself, have tried rebooting / resetting / reinstalling etc and the issue persists.

Bumping this up again - this issue is NOT resolved as of v7.4.1 on M1, M1 Pro, M1 Max, across 3 different machines.

Try closing all other apps you have opened. That did it for me after rebooting didn’t work as the first time. For what I can tell it struggles with multiple desktops on MacOS, which is what it does when in full screen mode. When you switch to another app and come back it playback suffers. But I agree, it is an issue that hasn’t been solved and it should be addressed.

This is an odd one. I had this problem too on M1 Air and on MBP16 M1 Pro. But I also had a problem with trackpad on MBP, it didn’t always register 2 finger scrolling. After erasing MBP to factory settings both trackpad and Infuse works perfectly, no more micro stutter. And that’s while streaming tv in browser.

the frame skipping exists on machines that have at least is 8-16GB RAM, can transcode multiple 8k streams, and display in 4K or 5k. Imagine how ludicrous your recommendation sounds. What’s the point of closing all apps? What if Microsoft word asked you to close all apps to write a sentence ?
That makes no sense.

The issue is with the infuse app, and they should definitely address this.

1 Like

Good for you that reformatting and resetting the machine gave you some peace.

However, in parallel, all other video apps appear to work with no stutter (Netflix, Plex, Vic, etc etc). So this is not a machine issue IMO.

Definitely software.

My M1 Max has 64 GB RAM and still skip frames on full screen mode. There’s nothing ludicrous with my answer especially when trying to help. Watch out your tone.

1 Like

I understand you are trying to help.
However

  1. “Try closing all other apps” : If you read the thread (and other threads stickied on top), then you are aware that folks have tried this without any luck. You are still recommending stuff AFTER all this.

  2. With a machine that has 64GB ram, “closing other apps” should really not be the recommendation under any circumstances. I am fully justified in calling out how ludicrous that sounds. You may not agree with it but that doesn’t change the facts.

  3. Please do not comment on my “tone” - I am trying to retain focus on the issue. Recommending erroneous and formerly tested actions leads to more aggravation.

In the future, please read the thread. It is fair to assume that most people who are running into this issue have read and tried some / all of the recommendations and failed to correct the issue.

There will always be a couple of laggards - but do not go out of your way to recommend bad workflows just because they didn’t read the thread.

Recent OS update seems to solve this issue for me (M1Pro).
And I remember “Plex HTPC for Mac” also had this exact same issue when I tested it a few months ago, but never happened on the Plex ipad app running on my M1Pro Macbook.
So it looks like some sort of system issue or specifc ffepeg version issue.

What OS version are you on?
I have 3 machines on 12.4 - and a 4th one on 12.5 beta - issue remains.

12.4.
Few months ago if i play movie in infuse fullscreen, there’re 50% chance it will drop frame seriously.
And if they menu bar is shown while on fullscreen, infuse will 100% drop frame. Seems to be gone for me now.

Anyway, i won’t hold my breath if the issue reappear on my Mac. IIRC infuse has filed a system bug report to apple back then, it means infuse think it’s system bug and can’t (or unable to) fix issue on infuse side.

Oh … thanks for this. I didnt see the link to the bug report.
Hopefully there is a fix at some point in the future.

Back to plex on Mac for full screen. The rendering leaves SO much to be desired with the plex native client.

For those still seeing issues here, do you have the ‘Vivid’ app installed?

It seems this may lead to issues when playing some videos.

No. I don’t have the vivid app installed on any of the machines. Have Plex and infuse only.

1 Like

Hi everybody,I just created an account to write about my findings, which hopefully will be helpful.

When I try to play HD SDR or 4K HDR files when plugged in to charger everything plays fine both in windowed and fullscreen mode (promotion enabled).
But when on battery I get severe stutter in fullscreen mode, but not in windowed mode. I then realised my MacBook had changed to power saving mode on battery. So when I change battery mode to automatic, everything plays fine in both windowed and fullscreen mode (promotion enabled).

So maybe this this could be energy mode related, and something changes systemwise when going from windowed mode to fullscreen mode (when energy saving mode is enabled).

16" M1 Max MacBook Pro 32GB on macOS 12.5.1
Infuse Version 7.4.4 (7.4.4228)

1 Like

This is helpful.
Doesn’t happen for my machines but interesting that you can replicate it.

Hopefully this will be resolved at some point.

I can reproduce this 100% on at least two different 4k HDR mkv files with:

  • MacBook Pro 15" M1, 16GB RAM, macOS 12.5.1
  • Infuse 7.4.4

Video is stuttering as if part of it where played faster, then hanging a bit, then play back faster, and so one, in a loop. The Loop itself lasts for a second roughly.

The issue is visible when these two factors are true:

  1. Low power mode enabled (even when plugged into power)
  2. Full Screen

As soon as I disabled one of these two, the issue goes away, it’s instantaneous.

So far, I only get this on 4k HDR mkv files (by HDR I mean HDR10 or HDR10+, not Dolby Vision). I did not test 1080p HDR or 4k HDR with different file format, so I’m not 4k or mkv format are triggers at all but HDR10/HDR10+ seems to be.

Interestingly, I had the issue on a MacBook Pro 2017 previously I believe, although I do not have this laptop anymore to retest in a more thorough manner. I just remember I had this choppiness on some HDR video files which was so bad, I would rather play it with VLC in tone mapped mode… I hadn’t found this thread at the time and hence didn’t do any more specific testing, I assumed it had to do with the mkv file.

2 Likes

Dude.

That low power fixed it for me on 4K on my M1 MBP. You are genius. :pray: :clap: :clap: :clap:

No bueno on Mac mini though. However immediate issue with laptop is resolved.