Choppy fullscreen playback in macOS Monterey on M1 Max

Both 7.3.0 and 7.3.1 are very bad in 4K HDR video playback. (other formats not tested)

7.3.1 is worse because it uses noticeably unreasonable amount of power.

7.2.1 is actually better than the two above although still a buggy one.

Needs a big fix to this ASAP!

i actually think 7.3.1 is worse than 7.3.0

Even when locked to 60hz i now get stutters.
i think 7.3.0 Never did this.

also looks like 7.3.1 is choppy when windowed. even worse with pro motion on.
but also 60hz micro stutters / freezes only the image dough the audio is fine

where can i get the old ones back

7.3.0 does stutter for about half a second even when locked to 60Hz just like 7.2.1 does.

7.3.0 is intolerable when ProMotion is on while playing 4K HDR local files.

Audio is all good though.

Have you tried the 7.3.1 update? It was just released.

Oh, I did. And I wish I could go back to 7.2.1, even with ProMotion on it stutters less frequently than both 7.3 and 7.3.1.

Would you be able to upload a sample file you are seeing playback/battery issues with?

Also, sending in a report (and posting the code here) would be super-helpful in looking into this.

can we get access tot the old 7.2.1 ?

If you’re seeing issues here in 7.3.1, I would as that you submit a new report (via Preferences > Email Us) and post the code here. This will allow us to get more insight as to what is going on.


if i press preferences nothing opens. i get nothing been like that since 7.2.1.

infuse->preferences doesn’t do a think at all

any updates on the problems ?

the preferences does nothing no menu or popup or whatever what am i suppose to see? been like that since 7.2.1 too.

Are you talking about the Mac version? When you go to the top menu bar under “Infuse” and select “Preferences” you get nothing?

A preference window should open centered in the main window. If you’re not getting this then I’d suggest you delete the app and reinstall it. Something may have been corrupted in the install.

yes on mac m1 pro . i reinstalled it. And than found out i can only go intro preferences when i am on the main-screen. not while watching a movie. so thats probably it. or are you suppose to get the preferences too when watching a movie

No, just when in the pre play screens. Now you can submit the requested diagnostics and post the code here.

Just play a video until you experience the issue you’re having and then stop it and go back to the main menu and submit the diagnostics.

just send one i will send a few in different movies.

Don’t forget to post the 5 digit code here when you do.

[a few freezes stutters fullscreen playback] Diagnostics: M8643

[a few freezes / stutters] Diagnostics: EMJ8P

[another stutter / freeze also in sdr movies] Diagnostics: Z83B9

1 Like

Strange but true i updated to new macos beta on my 16 pro to 12.2 beta 2 which was just released and it seems fixed with all movies i always use to test.

12.2 beta 1 was still bad. but with 12.2 beta 2 it’s finally running smooth fullscreen and windowed


That is encouraging to hear!

We’re going to do some more testing here to see if beta 2 helps address some of the system bugs we were seeing.

1 Like

On the latest (Infuse 7.3.2 build 3968), MacBook Pro (14-inch, 2021) 16GB M1 Pro:

4K HDR content when played fullscreen on my laptop display with the XDR preset and ProMotion refresh rate skips frames in a very noticeable (i.e. multiple frames skipped, maybe 500ms-ish?) way once every two minutes or so.

This happens on every 4K HDR film I’ve played so far, of varying bitrates, and it only seems to happen when in fullscreen which suggests it’s possibly unrelated to processor or I/O load.

This doesn’t seem to happen on 4K (or 1080p) non-HDR content, and I have not tried this yet on 1080p HDR.

Not sure what debug logs would be helpful

it happens with hdr and non hdr i only watch 4k mainly. and some 1080p on Rare occasions but they all stutter. its some problem with their adaptive sync (apple) i would say

or atleast they did. until i updated to macos 12.2 beta 2
so its not only infuse its problem. its starting too look macos had bugs and problems too still.

and indeed sometimes it stutters once every two minutes or some times 3 or 4 in once minute.

but so far since i updated to the latest beta it’s oke now no more stutters at all windowed or fullscreen. so there is a light at the end of the tunnel :wink:
and wait for 12.2 final. or when ur pc is non work critical maybe install macos beta profile so u can download it.

i am a die hard gamer with a lot of settings experience on windows with adaptive sync.
and to me it feels like adaptive sync never worked in that window or atleast was bugged.
the video is now smoother than ever even when not suttering. a lot of people don’t know that normal v sync also needs to be turned on in order for gsync or freesync to function fully it even gives lower latancy too with v-sync turned on during adaptive sync(freesync/g-sync)!

the same bugs / stutters i did feel when scrolling in the browser / safari. but not during dragging the window around.

1 Like