Choppy fullscreen playback in macOS Monterey on M1 Max

The upcoming 7.3.1 release adds full support for Adaptive Sync on ProMotion displays, which should help with what is going on here. :slight_smile:

Happen to have a beta for 7.3.1 I could test out to see if it resolves the issue?

1 Like

nice to hear any e.t.a ?

Happy to report that 7.3.1 seems to have fixed the issue at least in initial testing. Will test further today to confirm it’s resolved.

where can you get this 7.3.1 beta

Send a PM to James

I do watch the movies ( UHD ISO ) through a Wifi5 5Ghz( about 35 MB/s ) from a NAS, and it is choppy.
But it did work without any problems with the old version of infuse pro
Low bitrate movies through Wifi seem OK.
i’m going to copy the file to local disk to see if it is OK.

//update: Copying file to local SSD doesn’t solve the problem . Waiting for 7.3.1 upgrade.

Well according to the Upcoming Features thread it looks like it will be released publicly within a week since there aren’t many days left of December so no need to pm about the beta.

A post was split to a new topic: Choppy in 7.3.1

When will 7.3.1 be released? It is christmas and I cant watch any of my HDR movies anymore.

Cant downgrade, too because it is an Appstore app. If it is already fixed in beta, it would have been nice if you would have made it available to the public

A post was merged into an existing topic:

I know it can seem like forever but remember that this issue isn’t the only change in the upcoming release. There are several other changes and fixes so Firecore is going to do their best to get it perfect for release. It you got the choppy playback fixed but it broke something else then it’s even more of a problem.

On top of that it is a holiday season so I’m sure some folks are taking some time off for family and friends so that may play into things.

You can keep an eye on the changes and target release info here.

According to James it sounds like it might be just about ready and Apple needs to approve it:

1 Like

To all those still struggling with choppy playback - there is no fix in 7.3.1 unfortunately - But I know James and co are working on it - it is holiday season bear in mind.

As far as I can tell - this choppy playback issue is limited to ProMotion displays (from the new 14 & 16" MBPs, and the ProDisplay XDR).

There’s an issue with the sync in fullscreen only.

There is a workaround - If you fix your refresh rate to anything other than ‘ProMotion’ in Display preferences, this will enable you to watch content stutter-free. 60Hz works fine for example.

No, it’s not ideal, but if you can easily switch back to ProMotion when you’re not watching content, and I’m sure it’ll be properly fixed soon.

7.3.1 with support for Adaptive Sync on ProMotion displays is now rolling out on the App Store. :slight_smile:

1 Like

Thank you for your hard work during the holidays. Looking forward to this new release.

This new release has mostly fixed the issue for me. I still do get intermittent stutters but they occur far less frequently than before.

Sad to tell even after this 7.3.1 update there is still micro stutters when viewing fullscreen in all kinds of 4k / hdr movies. ow now i read the comment above the release. its still a known error. hope it gets fixed.
happy hollidays

There is a bug which we’ve reported to Apple which appears to be a system issue.

  • The issue is specific to the newest MBPs with M1 Pro/Max CPUs
  • The lags occur only in fullscreen mode when ProMotion is enabled
  • The issue may disappear for some time after a device reboot
  • It’s more likely to appear with 4K HEVC HDR10 content than SDR content.
1 Like

7.3.1 appears to consume a lot more power than the previous two versions namely 7.3 and 7.2.1, My 14’ MacBook Pro really gets warmed up while playing 4K HEVC HDR/DV content. Other video formats have not been tested.

Screen stutter issue continues to exist regardless of full screen mode or not although much less frequently than 7.3

Thank you. Appreciate the timely fix. Seems to be working fine in my brief test.

EDIT: There are still micro stutter. Turning off ProMotion fixes the problem.