Choppy fullscreen playback in macOS Monterey on M1 Max

The update did NOT fix the issue. I repeat: the Mac update didn’t do it. Yes, it seems better, but some videos still refuse to work without stuttering.

It may help to say what kind of videos are still having the issue.

Edit to add: Maybe also state what version number of Infuse and What OS. Since things are very fluid right now with updates on both sides.

Are these playing correctly in windowed mode, and then issues appear in full screen?

Which Mac do you have?

Yes, in windowed mode it seems okay, but full screen it’s still choppy on MBP 16" M1 Pro.

MacOS: 12.4
Infuse: 7.3.10 (7.3.4085)

Mediainfo from mkv remux video, but don’t know how much that helps as it seems to be every file thats choppy:

General
Format                                   : Matroska
Format version                           : Version 4
File size                                : 9.55 GiB
Duration                                 : 54 min 53 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 24.9 Mb/s
Encoded date                             : UTC 2022-05-15 21:19:12
Writing application                      : mkvmerge v67.0.0 ('Under Stars') 64-bit
Writing library                          : libebml v1.4.2 + libmatroska v1.6.4

Video
ID                                       : 1
ID in the original source medium         : 4113 (0x1011)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 54 min 53 s
Bit rate mode                            : Variable
Bit rate                                 : 22.9 Mb/s
Maximum bit rate                         : 33.0 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.460
Stream size                              : 8.77 GiB (92%)
Default                                  : Yes
Forced                                   : No
Original source medium                   : Blu-ray

Audio
ID                                       : 2
ID in the original source medium         : 4352 (0x1100)
Format                                   : DTS XLL
Format/Info                              : Digital Theater Systems
Commercial name                          : DTS-HD Master Audio
Codec ID                                 : A_DTS
Duration                                 : 54 min 53 s
Bit rate mode                            : Variable
Bit rate                                 : 1 997 kb/s
Channel(s)                               : 6 channels
Channel layout                           : C L R Ls Rs LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 93.750 FPS (512 SPF)
Bit depth                                : 16 bits
Compression mode                         : Lossless
Stream size                              : 784 MiB (8%)
Title                                    : DTS-HD MA 5.1
Language                                 : English
Default                                  : Yes
Forced                                   : No
Original source medium                   : Blu-ray

Text #1
ID                                       : 3
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 54 min 10 s
Bit rate                                 : 71 b/s
Count of elements                        : 705
Stream size                              : 28.2 KiB (0%)
Title                                    : English
Language                                 : English
Default                                  : Yes
Forced                                   : No

Text #2
ID                                       : 4
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 54 min 10 s
Bit rate                                 : 75 b/s
Count of elements                        : 748
Stream size                              : 29.8 KiB (0%)
Title                                    : English SDH
Language                                 : English
Default                                  : No
Forced                                   : No

Text #3
ID                                       : 5
ID in the original source medium         : 4608 (0x1200)
Format                                   : PGS
Muxing mode                              : zlib
Codec ID                                 : S_HDMV/PGS
Codec ID/Info                            : Picture based subtitle format used on BDs/HD-DVDs
Duration                                 : 54 min 10 s
Bit rate                                 : 51.4 kb/s
Count of elements                        : 1496
Stream size                              : 19.9 MiB (0%)
Title                                    : English (SDH)
Language                                 : English
Default                                  : Yes
Forced                                   : No
Original source medium                   : Blu-ray

Menu
00:00:00.000                             : en:Chapter 01
00:06:17.293                             : en:Chapter 02
00:17:35.137                             : en:Chapter 03
00:30:04.093                             : en:Chapter 04
00:35:45.810                             : en:Chapter 05
00:44:44.807                             : en:Chapter 06

A post was merged into an existing topic: 7.4 features not working

Agreed, and I have the same issue on my Mac as well…

All videos I watch stutter when there is a lot of movement in the video. For example, every time a camera tilts, pans or moves, the video starts to stutter. It is not too bad, but definitely noticeable. I am on a new MacBook Pro with an M1 Max. So performance is not an issue… :slight_smile:
I downloaded one of the files to play it with VLC, where it plays very smoothly. When you compare the two, the stutter in infuse is very obvious.

1 Like

Don’t have a lot to add, other than I’m still experiencing this issue. Have been sticking to quicktime in the meantime but hoping it gets fixed soon.

Using a Mac M1 Max, I noticed this on two titles, one on UHD Blu-ray ISO and the other on BDMV. By default it plays smooth, but when using Full screen mode there playback is skipping frames.

1 Like

Just found out that restarting the computer fixes the issue

1 Like

Unfortunately that is not true. It may have worked for you by pure happenstance. Most people on this thread, including myself, have tried rebooting / resetting / reinstalling etc and the issue persists.

Bumping this up again - this issue is NOT resolved as of v7.4.1 on M1, M1 Pro, M1 Max, across 3 different machines.

Try closing all other apps you have opened. That did it for me after rebooting didn’t work as the first time. For what I can tell it struggles with multiple desktops on MacOS, which is what it does when in full screen mode. When you switch to another app and come back it playback suffers. But I agree, it is an issue that hasn’t been solved and it should be addressed.

This is an odd one. I had this problem too on M1 Air and on MBP16 M1 Pro. But I also had a problem with trackpad on MBP, it didn’t always register 2 finger scrolling. After erasing MBP to factory settings both trackpad and Infuse works perfectly, no more micro stutter. And that’s while streaming tv in browser.

the frame skipping exists on machines that have at least is 8-16GB RAM, can transcode multiple 8k streams, and display in 4K or 5k. Imagine how ludicrous your recommendation sounds. What’s the point of closing all apps? What if Microsoft word asked you to close all apps to write a sentence ?
That makes no sense.

The issue is with the infuse app, and they should definitely address this.

1 Like

Good for you that reformatting and resetting the machine gave you some peace.

However, in parallel, all other video apps appear to work with no stutter (Netflix, Plex, Vic, etc etc). So this is not a machine issue IMO.

Definitely software.

My M1 Max has 64 GB RAM and still skip frames on full screen mode. There’s nothing ludicrous with my answer especially when trying to help. Watch out your tone.

1 Like

I understand you are trying to help.
However

  1. “Try closing all other apps” : If you read the thread (and other threads stickied on top), then you are aware that folks have tried this without any luck. You are still recommending stuff AFTER all this.

  2. With a machine that has 64GB ram, “closing other apps” should really not be the recommendation under any circumstances. I am fully justified in calling out how ludicrous that sounds. You may not agree with it but that doesn’t change the facts.

  3. Please do not comment on my “tone” - I am trying to retain focus on the issue. Recommending erroneous and formerly tested actions leads to more aggravation.

In the future, please read the thread. It is fair to assume that most people who are running into this issue have read and tried some / all of the recommendations and failed to correct the issue.

There will always be a couple of laggards - but do not go out of your way to recommend bad workflows just because they didn’t read the thread.

Recent OS update seems to solve this issue for me (M1Pro).
And I remember “Plex HTPC for Mac” also had this exact same issue when I tested it a few months ago, but never happened on the Plex ipad app running on my M1Pro Macbook.
So it looks like some sort of system issue or specifc ffepeg version issue.

What OS version are you on?
I have 3 machines on 12.4 - and a 4th one on 12.5 beta - issue remains.

12.4.
Few months ago if i play movie in infuse fullscreen, there’re 50% chance it will drop frame seriously.
And if they menu bar is shown while on fullscreen, infuse will 100% drop frame. Seems to be gone for me now.

Anyway, i won’t hold my breath if the issue reappear on my Mac. IIRC infuse has filed a system bug report to apple back then, it means infuse think it’s system bug and can’t (or unable to) fix issue on infuse side.