Changing SMB port possible?

Hi everybody. Because of some issues with my WD My Net N750 router (no files playable per external USB HDD) I’d like to try fiddling around with the SMB ports for defining media sources. Is this even possible in aTV black? If not is there a chance by editing a system file?

This is currently not possible. Sorry.

Thank you James. I probably need to change my router anyway. This new WD’s are really crap. :frowning:

 

lol i have the exact same router and same issue: playback error on any file.
it works however with every other device in the network (TV, PC, Android tablet, etc.) even XBMC on ATV2 plays back the files.

SMB shares from WD750 are really slow in XBMC, i use FTP share instead…much faster.
i don’t think it’s the router at fault here man… 

Thanks for your reply. You are right, I should not blame WD only. It’s probably a strange combination with some code in Mediaplayer and the firmware of the WD router. I have also made the same experience like you. Files on the external USB are working with XBMC in ATV2 and other systems in the network like Windows PCs. But I’m not optimistic that this issue can be resolved. I have already created two tickets with Firecore but they are always asking for sample files which makes no sense. They would instead need sample hardware which I can’t ship. :slight_smile:

I mentioned this in another thread, but can you confirm a username/password are being entered on the Apple TV to connect via SMB?

Currently guest access for SMB streaming is not supported on the ATV2, so a username and password will be required in order to connect and play files.

Hi James. Yes I did, I don’t allow guest access to my files in the network anyway. Even tried with different user names and setting back passwords. I can always see the order structure and the files (even with mediadata) but when it comes to playback it always shows the error message “Playback error. An error occured loading this content”. I know the content is not the problem because every single file (mkv, mp4, avi etc…) works in XMBC (unfortunately I don’t like XMBC). I even re-installed ATV2 and re-jailbreaked, tried different iOS versions, but always out of luck.

 

aha!
in my setup i have no user/pass on the SMB share!
I will try setting up some access credentials and see what happens. 

ok, here’s the result.
set up user/pass on the SMB share, now INfuse can’t see it automatically.
I add it manually, connects OK.

i can browse the content of the HDD but no file can be played.
Playback error on any type of file.
XBMC plays them OK.