Change in wording for macOS 'Playback' menu

This is a suggestion for an API improvement which will enable a slight changes in wording for the ‘Playback’ menu in macOS. Currently the topmost item on the ‘Playback’ menu always says ‘Play/Pause’, regardless of the media state.

My suggestion is to keep it consistent with other player apps (VLC, IINA, Music, Podcasts etc.). For the menu item to say ‘Play’ when media is paused and ‘Pause’ when the media is playing. On top of being an UX improvement, this also will become extremely helpful in building accurate automations using Keyboard Maestro (to check for the media state).