Cast is missing for numerous movies

I have the problem that the cast is not displayed for numerous movies,
For example, no cast is displayed on the Apple TV, but it is displayed for the same movie on the iPhone and iPad.
I have already tried renaming the movie and then reassigning the metadata.
But the database does not seem to read the cast data.
Before I delete the whole database I wanted to know if there is another way to complete the data again.

Apple TV Modell A2843 (128 GB)
tvOS 13.3.2

Iphone V13.3.2

IPad V 13.3.2

Infuse Pro V 7.4.10 (4329)

Icloud Sync is on

1 Like

So the movie is identified on the Apple TV, it’s just missing the cast? Same file as those working on iPad and iOS? Do you use local .nfo?

Have you tried the “Refresh Metadata” (and maybe “Scan for Changes”) option(s) on the Library settings page?

Right, all devices access the same NAS with the same movies.
I only use nfo files for homemade vacation videos;

and yes, I have already done a complete rescan.

Just to cover the bases, what version number of Infuse on ATV, iPhone, and iPad?

Are you using Plex or Jellyfin etc. or only Infuse?

Can you provide the names of a couple of movies that exhibit this?

All devices use Infuse Pro V 7.4.10 (4329)
I only use Infuse (so no Plex or similar)

Examples for Movies are:
Apocalypse Now.mkv
Barry Seal – Only in America.mkv
Bullet Train.mkv
Catch me if you can.mkv
Ein Quantum Trost.mkv

I also tried deleting a movie and then inserting it again - without success;
In another case the cast of a wrong movie is displayed although I made the correct assignment several times.

Somehow the assignments are not taken over into the ATV database

1 Like

Do you not include the year in the movie file names?
“Apocalypse Now (1979).mkv”

1 Like

I’m just using the movie name - it’s all historical…
so far there have never been any assignment problems.

I have now found a way to correct the missing cast and the incorrect mapping…

until now I had my movies in the following folder structure:
-Folder: Abyss
-Folder: Abyss
-File: Abyss.mkv

I moved the movie from the second folder structure to the first one
-folder: Abyss

  • File: Abyss

Is now just a bit tedious to find and move the affected movies…

1 Like

I don’t believe that would cause the problem; but changing the folder location makes Infuse re-index the file instead of pulling from cache as just deleting and copying back the same file with the same filename.

This is because Infuse is designed to work with removable media and cloud sources so a file (or entire terabytes’ worth of them) temporarily disappearing won’t cause the system to slow down when reconnected — the metadata is preserved.

I am curious why you chose that folder structure. What’s in the first “Abyss” folder that’s separate from the second level one?

Also, as @NC_Bullseye suggested, I wholeheartedly agree best results and future troubles can be avoided if you add the years to all your filenames — and the containing folders, too (though that may be less important).

If you do that, the change in filename will also result in the metadata being recreated.

At this point, I’d suggest the best thing to do, to be sure, is deleted the metadata from settings and (if connected, iCloud) and rebuild overnight (or whenever you have an hour or however long depending on the size of your library and speed of your internet). It’s possible that TMDB was just glitching when you last indexed. I had dozens of bizarre mismatches recently during a library rebuild on one AppleTV that didn’t occur on an identical second one (neither connected to iCloud) with the indexings being started maybe half a day apart (from the same NAS).

Blue skies …

1 Like

My folder structure has grown historically.
When I digitized my DVD / Blue-ray collection I created a folder for the main movie and a folder for the “behind the scenes”.
Both folders are in a parent folder that has the name of the movie.

I will use the suggested naming convention at least for the new films and slowly change everything - it is rather a longer project.
thank you

1 Like

Don’t I know it… LOL. No worries, and good luck!