Can't upgrade

Went to upgrade to 4.1.4 (of course after reading the posts…)
Anyway, I have good internet (5 bars). I go to Maintenance>Manage Plugins>Maintenance.
I select it, a URL displays for a fraction of a second and I get “An error occurred”.
I have re-booted. The same thing happens, except I get about one second of downloading, than the same message.
As this message is none too helpful, I was wondering if anyone had an idea as to what is happening.
Thanks, HNick