Can't uninstall XMBC

When I try to uninstall XMBC via the Maintenance menu it fails with an error:

Removal Failed!  E: dpkg was interrupted.  you must manually run ‘dpkg --configure -a’ to correct problem.’

Then when I got to the main menu screen I see this:



Anyone else seen this?  Can I safely delete the application via SSH?

yes, same here.  how can i fix?? 

Same here

to remove XBMC u need to do a dpkg --configure -a” when u logdin to ssh and u need to do a “find / xbmc | grep xbmc” and remove evrey thing it finds whit the namne xbmc

Not exactly the way I had hoped :wink: Hope it get’s fixed in/ before the final release.

We’re looking into a few similar issues.

In the meantime you can connect via SFTP and remove the ‘XBMC.frappliance’ folder (located in the /Applications/ folder) manually. After this simply restart the AppleTV and remove the XBMC through the Manage Extras menu as before to complete the removal.

this is the way i fix the problem i installd xbmc the gui way and removd it the way i haw whriten in my mess behore this, after i removd it i ssh agen into and 

You must install from Cydia at least once before you are able to install a nightly build. This is to make sure all of the proper dependancies are met.

cd /tmp




dpkg -i xbmc-20110902-139071b-master-atv2.deb


rm xbmc-20110902-139071b-master-atv2.deb




more info


// Sorry About My Spelling I´m Dyslectic //


Thanks, that worked just fine!

I had the same problem so just wiped my atv2 & started again all fine now.

Worked for me. Can XBMC be reinstall later without XBMC.frappliance folder ?

This worked for me

ssh as usual; once connected 

apt-get autoremove