Can't stop Plex DVR recordings from showing up in Infuse?

I use Plex with an HDHomeRun for over-the-air TV viewing/recording. Because of the file format, I only use Plex to view these DVR recordings. In Plex, they are stored in a dedicated library called “DVR Recordings”.

In Infuse (on iOS, Apple TV and macOS), I have the “DVR Recordings” disabled/unchecked via Settings > Library > DVR Recordings as I don’t want these files to appear in Infuse. But, these files are constantly showing up in the “Watching” row at the top of the app (iOS/tvOS/macOS; happens in all three apps).

I’m unsure why they’re showing up if I don’t have the (Plex) library enabled/checked in Infuse? How do I go about keeping these files out of Infuse?


It’s not the library you need to remove the DVR recordings folder from it’s in the Share settings.

On ATV in Infuse you’ll go to Settings > Network Shares > Saved Shares (select the one that has the DVR recordings on it) > Favorites. Then you’ll either remove the Favorite with the DVR recordings or you’ll have o move the DVR recordings folder out of any of the favorites to a new folder not included in the ones Infuse lists.

Edit to add: I don’t run Plex but I think it works the same way for this.

I had a look at the settings you suggested and “DVR Recordings” was already removed from there as well.

Here’s a photo of the Saved Shared sources (Plex libraries); you can see “DVR Recordings” isn’t checked…


And here’s the screen prior, showing the favourited Saved Shared sources (just “Movies” and “TV Shows”)…


But, the files within “DVR Recordings” still show up in the “Watching” row (there’s no other way to access these files within Infuse; just via the “Watching” row).