Can't ssh?


I have JB my apple tv 2g with GP and now I can't able to access my aTV using terminal. I am getting following message. To rectify this problem what should I suppose to do.

I can't able to ssh to my apple TV 2g. I am getting error.  :(It wasn't problem earlier jb with Seas0npass.  I am getting this error:



Someone could be eavesdropping on you right now (man-in-the-middle attack)!

It is also possible that the RSA host key has just been changed.

The fingerprint for the RSA key sent by the remote host is


Please contact your system administrator.

Add correct host key in /Users/Dharmin/.ssh/known_hosts to get rid of this message.

Offending key in /Users/Dharmin/.ssh/known_hosts:2

RSA host key for has changed and you have requested strict checking.

Host key verification failed.""""


I will appreciate any feedback.


you gotta open up the known hosts file and delete the ONE offending key. so the whole second line just erase it from known hosts. when you try and connect it will give you a new key.


you gotta open up the known hosts file and delete the ONE offending key. so the whole second line just erase it from known hosts. when you try and connect it will give you a new key.



Could you pl explain me in detail? How? I am not expert in mac.

You have to use a software tool to access your APPLETV remotely.  Its like you are doing remote control of your apple tv.  The command in UNIX is TELNET and is used by DOS and maybe by IOS also.  just look up what TELNET means on wikipedia.  Should give you an idea.  Think they call is DUCK something in the mac world, as a tool.

You get access to your HOSTS file (not sure of the exact name), and make sure that no one else can get into your system.

Am not convinced this is happening on your ATV.  Think you are having some other issue.


see with ssh the known hosts file. what it does is when you first connect to a remote ssh server, like atv, it gives your computer a host key and it keeps it. its there for security reasons, like the msg above says. so if you ssh'd into atv then restored the atv.. the atv's host key is different then the one on your computer, so it wont let you in cause they dont match.. the .ssh folder is hidden inside your home folder.. so go into safari i guess.. im not a mac user either.. go into the address bar at the top and paste /Users/Dharmin/.ssh           you should see the known_hosts file just open it up with, anything that can read it, and delete the offending key and save. in your case the second key.. its a very very long string of what looks like gibberish. thats all.


actually i doubt you can do it in safari. you'll have to do it from your file browser just paste /Users/Dharmin/.ssh and you should beable to see the file and edit it.

Just open terminal. Type cd .ssh . Then delete the known_hosts file. You can do this by typing rm known_hosts. Now type cd and press return. You should be in your home folder. ssh will now work. Of course you could just edit the file but depending on how often you use ssh to other systems this may not be worth it.


Thank You all. Now I can able to log into my atv.

The other thing I noticed is after JB I have connected my atv to my HDTV and everything was fine. But when I removed AC plug from the wall to rearrnage my atv and my network was lost. I could not able to connect to netwrok. To get back to my network I have to restore with itune and JB again then connect back to HDTV. It looks network will be there when you unplug ac plug first time but when you unplug cable again ( for some reason)then network will be lost. IS it true? Why I am getting network issue?

Thanks again to all.


I've tried all of this. I've deleted known_hosts and I still cannot log in with "alpine."

I'm stuck. Any suggestions? This could be an expensive frisbee :-)

Other than SSH not working out for me, everything else is cool. XBMC is running without a hitch. I just want to do some playing and try to install some new skins.

Did some more poking around and using SFTP works fine using root and alpine. Still no SSH. At least I can access the box now, but still curious.