Can't SSH into atv2

I recently jailbroke using seas0npass. There is a Firecore logo in the bottom right corner of the screen so that indicates to me that it is successfully jailbroken. I can’t seem to connect to my atv2. I am at a hotel and using their network so maybe that can be the issue. Under IP address it shows (DHCP 10.40…) I am using winscp and under host name I enter the ip address (10.40…), ‘root’ and ‘alpine’ for username and password. It does not connect and just prompts to retry. Is there something I am doing wrong or maybe it doesn’t like the hotel network? I get the same issue using Putty as well. It does not connect. I’ve also tried to ping the unit in cmd with a time out message. My goal is to install xmbc.

Are you on the same subnet as the ATV2? It’s also possible that they are blocking SSH (yes, even internally) on the hotel network.

Yes, same subnet. I was wondering SSH blocking as well. Is there an easier way to jailbreak and not having to SSH? Maybe like the iphone where all u need is cydia.

side note, shouldn’t I still be able to ping the unit? Or is that still considered SSHing?

You pretty much have to be able to SSH in regardless of what is doing it - why don’t you connect the ATV2 directly to your laptop (I presume) with a cross-over cable and SSH in that way.  You’d have to give it a static IP like 192.168.1.1 and give your laptop 192.168.1.2  - then once you’re done you can change it back to DHCP and put it on the hotel network.

 

That’s something else (ICMP) but that could also be blocked.

Can you explain the process? I presume cross over cable is the same as a regular ethernet cable or is it something else?

 

I really appreciate the feedback. Thanks!

You may not need a cross-over cable if the ATV2 or your laptop is smart enough, you could just try a normal network cable.  Very simply - cross-over allows two network devices to talk without a switch (http://en.wikipedia.org/wiki/Ethernet_crossover_cable).

 

As for changing the IP on the ATV2 and laptop… I could explain it but a quick Google will get you going.

Thanks!

 

Or maybe I can use another jailbreak method that allows me to install xmbc without SSH. Any ideas?

Okay so I tried last night using a cross over cable and sharing my internet connection through my laptop. I got to SSH into the device using both Putty and WinSCP however when I tried to update the list it got stuck at 33% and didn’t continue. I think I will have to wait until I go home and try it wirelessly on my network.

sounds like a plan, most likely a whole bunch of non-standard ports are being blocked on that hotel LAN

Had can’t connect using ssh.connection closed.
Tried cyberduck and even putty, all same
Version 11.0 Eden on apple tv2 xbmc.
Proved IP address correct using ssh, so you can talk to appletv2, but can’t go any further.
Password is root and alpine, port 22 .
So just about to give up …
Answer: go into nito TV icon,next to xbmc
Go to manage
Go to packages
Down to: OpenSSL

Bobs your uncle
Could connect and clear cache
Who hoo