Can't set default language for subtitles

I’ve set the default language to English both in Infuse and in the Apple TV settings. But it just keeps choosing my Swedish subtitles anyway. Any idea how to fix this?

What version of Infuse? There have been several releases lately and there are some subtitle issues addressed in some of them.

Latest - 6.4.3

Whats the difference between choosing English (Sweden) vs English?

Just making sure I cover all the bases, do you have the English subs downloaded already?

I’m not quite sure what the difference would be between those two are. I’d have to download both and look at them with a text editor to tell.

Are these embedded subtitles, or external?

If embedded, do you know if the correct language tags are set?

What do you mean by “downloaded already”? I have the sub file (srt) stored in the same folder as the movie file. “Movie_name.en.srt”

I have mostly external srts and embedded seems to be working the same. When its working I think its because I’ve already manually chosen english subs some other time.

If you have a chance, can you post a pic of the subtitles list you are seeing in Infuse (when Infuse incorrectly selects the Swedish subtitles)?

hOh i’m so sorry for the late reply, missed it somehow. Here’s a pic of what you wanted :slight_smile: https://imgur.com/lUcrycF

Ok, so you have external Swedish subtitles, but you would prefer to use the embedded English subtitles?

Maybe a silly question, but why do you have Swedish external subtitles?

Often so yes. I prefer English, embedded or external. Problem is still there unfortunately.

I have external swedish subtitles since the movies/shows I get almost never has other than english subs already embedded. So I then let the video go through bazarr that automatically search and downloads the correct swedish sub and place it in the video folder. Hope that makes sense.

Can I make anything to make this work?