Cant seem to jailbreak cause restoring prob's???

i cant seem to jailbreak through season pass its gets all the way to restore and then says this…even if i do a restore from apple not even goin through season pass… so my question is what iam i doin wrong?


I went through this as well when trying to do this for the first time.

Make SURE you have downloaded the right image file for the VERSION of ATV2 firmware you have.

Then hold down the option key as you click and select the file you just downloaded.

This should clear that issue up.Hope this helps




yeah i did that to i have 4.4.2 i tried my verison and nothing happened and then i thought i will just update it through my mac on itunes and that didnt work either idk iam thinkn it might b my cable i guess i have tried it the past three days and no luck



Try changing your hosts file to point to Apple servers instead of cydia. There are guides on here that tell you how to do that.

edit added:

Also you could try using iREB to get the device into a pawned DFU state then try and restore. It may go all the way to the end in iTunes and then still come back with an error message but it may have actually worked so unplug, stick in in your tele and look for the FC logo.

Well I actually did that I forgot to mention that I did that I did it on tiny umbrella…and I have hook it it to c if it actually jb it and it didn’t I was thinking the same thing that it might have worked…but I have not tried iREB never heard of it…I’ll try anything at this point…I might just give up and hope the unteathered JB for 4.4.4 comes out soon

Yeah give iREB a try it just put’s it into a deeper state of DFU as AFAIK. Do you have another machine you could try it on. Whenever I hit problems with any Apple products I usually try different methods on different machines like my PC then Laptop… worth a try… good luck let me know how you get on


I’ve got exactly the same problem. Everything worked fine up to the 28th and the box crashed, I restarted and it looks as though it isn’t JB’ed any more. But the SW version hasn’t increased, I’m still on 4.3. When I tried to re-JB it gave the error should by the OP, and when I tried to a straight restore in iTunes it gave the same error. Has Apple locked my box or something…

Only difference is I’m using a different cable, could this be a contributing factor? Also, why did it suddenly stop working? I can still SSH to the box and updating everything doesn’t solve it.

Any help would be great.


No your box won’t be locked, again try putting the device into DFU mode using iREB (I think it’s currently only windows software??) Make sure iTunes is bang up to date and try and restore. You could also try plugging the power in as I know some folks have been having issues with low power supply USB cables. 

Right, I’ve fixed it!! Did a bit of googleing and looks like the error is common on iPhones. Here’s steps to fix:

edit the hosts file and remove the static entry:


open terminal window

$ sudo nano /private/etc/hosts

scroll down to the entry and comment it out (# before line)

flush the dns cache:

$ dscacheutil -flushcache

restart Seas0nPass and do it again…voila!


Now I have the FC logo back but no XBMC, I guess I need to re-load it etc. This time I will be disabling auto-update!

And yes I did have to plug it in to force the DFU, using a Nokia instead of Blackberry USB lead this time! Knew these old phone leads would come in handy one day! :slight_smile:

Glad you got sorted mate. I use the Nokia cable myself but still plug it in every time.