Cant see my files in media player

Hello,

Here’s my setup:

  • Asus Router with built in DLNA server.
  • 1tb USB hard drive connected to the router and shared over network.
  • XBMC on ATV2 is able to see and play files over the shared DLNA server.
  • My Samsung TV is able to see and play files over the shared DLNA server.
    However, Media Player is able to see the server but no files are shown, it gives 0 in bottom left corner where it shows movies and shows count.

I tried to scan but still no luck…any help is appreciated

Regards.

Which option (AFP, NFS or SMB) are you using to stream from your router, as we don’t yet support DLNA.

DLNA

This is my router…i dont think it support anything but DLNA

http://www.asus.com/Networks/Wireless_Routers/RTN66U/

Says it supports SAMBA which is a implementation of the SMB protocol

Yep, it looks like you can use SMB (SAMBA) to connect to your NAS from the Apple TV.

Keep in mind you will need to enter a username and password when streaming via SMB to the Apple TV.

Great its working now but its showing all my movies and tv series under “Others”…is there a way to fix this as i had them organized on my server but am not sure why all came under one wrong location.

Also if the movie cover is wrong, is there a way to change it?

Many thanks for your help :smiley:

Is metadata fetching enabled in the Media --> Settings --> General menu?

You may also try correcting metadata as described here.