cant see my computer in shares for media player

before upgrade work perfect now i cant see my computers in media player share i used windows pc any help is apreciate thanks

I’m having the exact same problem. Before upgrade, everything worked fine. After the upgrade, no shares show up, and my connection tests fail. Uninstalled Media Player and reinstalled to no avail. Ideas?

same here.  Please FIX ASAP or allow roll back to prior version!!!

Have you tried rebooting all your network hardware and PC/Mac/NAS to get everything back to a clean state? That sometimes seems to help with this sort of issue.

I’ve power cycled the ATV2, and I’ve rebooted the PC it’s trying to talk to. Other machines in the house can access those same shares without a problem. I didn’t know rolling back to the previous version of media player was an option - it seems like that’s my only shot.

On my NAS the HDD gets the name of volume_1. Before i could add volume_1 and i could find my folders i created like tv shows and movies. Not now. I deleted the share and added it once again but expanded volume_1 so i could see my folder, and then added them directly. Now i can find my movies, BUT, i have set the folder name to TV Shows, but i get my tv shows now under other and not tv shows in the library. Tried to rename it to TV-Shows but then i got both series and movies under movies.

Does anyone know what the name standard should be for the damn idiotic library to get it right.
OR! is there a way to not have to use the library, like it was before?
So for the ones that cant see the movies and stuff on the share, try to share the sub folder and not the complete drive.
That worked for me, now i just need to clarify what the name standard should be so the tv shows will be shown under tv shows and not other. 

I use the media shares to stream to my tv. Seems like rolling back would be the best option until they get the update correct. What’s the best way to roll back to the prior version?

I rebooted my NAS and Router and was still unable to see the shares. So, I rolled back to the earlier version and everything is back to normal.

The process:

Backup your setting under Maintenance. Follow the steps for jailbreaking - Right click on create IPSW and select the 5.0.2 version. Complete the jailbreak and then install ATV Flash Black 2.2 version. Install all the applications and restore your settings from Maintenance. You should be good to go.